LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-10-2018, 02:34 PM   #1
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 154

Rep: Reputation: Disabled
changing boot order Mint Xubuntu


I have both Mint and Xubuntu on my PC with Mint as first choice,but I always use Xubuntu. Is there a way I can move Xubuntu to the top of the list?

I rarely use Mint and when I last opened it I did a massive update, but then I can't access the internet and several other programs.

I thought I could update the programs like Firefox, but whenever I try to update via the software Updater I get a list of variations and I don't know which ones to update.

I know I am "packing" more than one question but they are related for me.
 
Old 05-10-2018, 03:29 PM   #2
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 19.2 MATE, MX-19, antiX, Manjaro
Posts: 2,973
Blog Entries: 17

Rep: Reputation: 1097Reputation: 1097Reputation: 1097Reputation: 1097Reputation: 1097Reputation: 1097Reputation: 1097Reputation: 1097
RenH,

Quote:
I rarely use Mint and when I last opened it I did a massive update, but then I can't access the internet and several other programs.
If you have not used Mint for a long while, you could have the famous virtualbox update which wreaked havoc a few weeks ago. I also lost my internet connection and I was unable to open several programs:

https://www.linuxquestions.org/quest...pc-4175626377/

The solution is to open Terminal and use this command:

Code:
sudo apt-get purge virtualbox-guest*
Then reboot.

You may find this link useful for changing the boot loader settings:
https://www.ostechnix.com/configure-...-ubuntu-16-04/

NB Do make a backup of /etc/default/grub file before making any changes.

It may also be a good idea to download and burn Rescatux to DVD or USB before you start:
https://www.supergrubdisk.org/wizard...with-rescatux/
 
1 members found this post helpful.
Old 05-10-2018, 05:05 PM   #3
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 9,059

Rep: Reputation: 1937Reputation: 1937Reputation: 1937Reputation: 1937Reputation: 1937Reputation: 1937Reputation: 1937Reputation: 1937Reputation: 1937Reputation: 1937Reputation: 1937
Quote:
I have both Mint and Xubuntu on my PC with Mint as first choice,but I always use Xubuntu
The most likely scenario to get this is installing Mint after Xubuntu and accepting the defaults thus putting Grub boot code from Mint in the MBR if in fact, you are using the older Legacy boot rather than UEFI. Simplest way to change that situation is to boot into Xubuntu and simply install the Xubuntu Grub code to the MBR.

Quote:
sudo grub-install /dev/sda
The above will only work if both systems are on one drive and that drive is seen as sda and you are using a Legacy system, so if that is not the case, you need to post more details. If you plan to keep Mint and Xubuntu, it might be easier to edit the /etc/default/grub file to set the Xubuntu menuentry first.
 
Old 05-10-2018, 06:22 PM   #4
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007
Depending on which installation controls the boot sequence, you would edit '/etc/default/grub' to read 'GRUB_DEFAULT=1'. Then run 'update-grub'. That should give you xubuntu as the default boot.
 
Old 05-10-2018, 06:32 PM   #5
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163Reputation: 1163
Quote:
Originally Posted by AwesomeMachine View Post
Depending on which installation controls the boot sequence, you would edit '/etc/default/grub' to read 'GRUB_DEFAULT=1'. Then run 'update-grub'. That should give you xubuntu as the default boot.
I too have done that and had complete success.

-:::-Remember the first entry in the Grub Menu is 0. Since Mint has the boot (automatically goes to Mint if you do nothing) you would edit the default/grub file in Mint-:::-

You can also add a picture to your Grub Menu if you don't like the traditional black and white Menu by using Grub Customizer.
 
Old 05-11-2018, 02:42 AM   #6
Nobutarou
Member
 
Registered: May 2017
Posts: 42

Rep: Reputation: Disabled
I guess you mean GRUB order. Using grub commands is nice user-friendly way. But they just re-creates /boot/grub/grub.cfg. Therefore, you can modify /boot/grub/grub.cfg by your hand (and you can learn grub rules). You can change "set default=". "set default=0" sets the first "menuentry {.....}" as default. "set default=1" sets the next, "set default=2" sets the next next,,,,,.

If you put your /boot/grub/grub.cfg, you can get clearer answer.

If you mean order of UEFI boot loader, you can change in BIOS setting menu.

Thanks,
 
Old 05-11-2018, 09:13 AM   #7
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007
If you manually edit /boot/grub/grub.cfg, your edits will be lost each time update-grub is run.
 
Old 05-11-2018, 10:38 AM   #8
_roman_
Member
 
Registered: Dec 2017
Location: _Austro_Bavaria_
Distribution: gentoo / linux mint
Posts: 433

Rep: Reputation: 29
Quote:
Originally Posted by AwesomeMachine View Post
Depending on which installation controls the boot sequence, you would edit '/etc/default/grub' to read 'GRUB_DEFAULT=1'. Then run 'update-grub'. That should give you xubuntu as the default boot.
Yes. only smart answer.

but much easier is to edit grub.cfg by hand as root user (superuser). Assuming you are using grub2 bootloader

look for this line

" set default="0"
"

every boot entry start with 0. the counting starts with 0, 1,2,3, ...

Just set the number you want and safe it.
 
Old 05-11-2018, 10:40 AM   #9
_roman_
Member
 
Registered: Dec 2017
Location: _Austro_Bavaria_
Distribution: gentoo / linux mint
Posts: 433

Rep: Reputation: 29
Quote:
Originally Posted by AwesomeMachine View Post
If you manually edit /boot/grub/grub.cfg, your edits will be lost each time update-grub is run.
Because every bad binary distro, includes any ubuntu based, does overwrite stuff which it should not do. I wonder what a binary distro does when you use chattr magic on grub.cfg
 
Old 05-11-2018, 11:26 AM   #10
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 8,711
Blog Entries: 13

Rep: Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936
Quote:
Originally Posted by _roman_ View Post
Because every bad binary distro, includes any ubuntu based, does overwrite stuff which it should not do. I wonder what a binary distro does when you use chattr magic on grub.cfg
Let's keep posts on topic and if there are personal biases about distribution types, perhaps people can create their own discussion threads for those points of discussion.
 
1 members found this post helpful.
Old 05-11-2018, 01:59 PM   #11
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 154

Original Poster
Rep: Reputation: Disabled
Thank ye, all. It looks like another project. I will study carefully your answers then plan my approach and inch my way along in the next few days [or weeks whenever I try to make a change].
 
Old 06-07-2018, 02:17 PM   #12
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 154

Original Poster
Rep: Reputation: Disabled
THANK YOU BEACHBOY2! I followed your instruction and it worked. The long delay before acting was caused by my hesitation [kept getting "sidetracked"] until I decided to bite the bullet and give it a try.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI HP250 Cannot boot my new istall without changing Boot Order every time DiBosco Linux - Software 3 07-10-2014 08:09 PM
grub question changing boot order making windows boot first nfsutim Linux - Newbie 29 10-27-2012 12:53 PM
Changing Boot Order pwellkidz18F4 Debian 15 11-01-2007 12:11 PM
Changing boot order CornMaster Fedora 13 10-04-2005 10:13 AM
changing the boot order coopns Linux - Newbie 11 09-14-2004 07:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration