LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-12-2011, 10:59 PM   #1
tux-junkie
Member
 
Registered: Jan 2005
Location: Atlanta, GA
Distribution: Debian, Fedora
Posts: 35

Rep: Reputation: 0
Question change display settings without using a GUI?


i have debian squeeze installed on an old computer to use as a file/web server. i had an extra monitor laying around and wanted to use it with the server. after about half an hour or so, it turns off and i have to press a key on the keyboard to get it to turn back on. i'm not sure how to keep it from doing this without installing a gui. does anyone know how to do this?
 
Old 07-13-2011, 01:22 AM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
If you're just using this as a server, it doesn't need a GUI or even monitor (once its running).
Are you trying to use this as a desktop as well?
 
Old 07-13-2011, 08:12 AM   #3
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721Reputation: 721
Quote:
Originally Posted by chrism01 View Post
it doesn't need a GUI
Where did the OP say that (s)he wants to use a GUI?
 
Old 07-13-2011, 09:37 AM   #4
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,074

Rep: Reputation: 386Reputation: 386Reputation: 386Reputation: 386
Quote:
Originally Posted by bloody_maiden View Post
i have debian squeeze installed on an old computer to use as a file/web server. i had an extra monitor laying around and wanted to use it with the server. after about half an hour or so, it turns off and i have to press a key on the keyboard to get it to turn back on. i'm not sure how to keep it from doing this without installing a gui. does anyone know how to do this?
I think you are looking for setterm, look here for example.

http://www.cyberciti.biz/tips/linux-...ing-blank.html
 
Old 07-13-2011, 06:37 PM   #5
tux-junkie
Member
 
Registered: Jan 2005
Location: Atlanta, GA
Distribution: Debian, Fedora
Posts: 35

Original Poster
Rep: Reputation: 0
thank you for all the replies. sorry if i wasn't very clear... i don't want to use a gui and i know i don't need a monitor. i just have this monitor sitting around and wanted to use it for something. i just want the monitor to constantly display running processes on the server without needing a keyboard connected to it as well.

when i tried the command "setterm -powersave off -blank 0," it says: "cannot <un>set powersave mode." does anyone know of a way around this?

Edit: would "setterm -powerdown 0" have the same effect?

Last edited by tux-junkie; 07-13-2011 at 06:41 PM.
 
Old 07-13-2011, 06:44 PM   #6
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
I was just trying to clarify the problem ...
 
Old 07-13-2011, 06:51 PM   #7
tux-junkie
Member
 
Registered: Jan 2005
Location: Atlanta, GA
Distribution: Debian, Fedora
Posts: 35

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by chrism01 View Post
I was just trying to clarify the problem ...
yes, i'm sorry i wasn't more specific in the initial post. i don't really have enough RAM on this system to use it as a desktop, so i'm just using it as a samba/ftp server.
 
Old 07-13-2011, 07:51 PM   #8
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
no worries
You post #5 is much clearer; good luck
 
Old 07-13-2011, 09:15 PM   #9
tux-junkie
Member
 
Registered: Jan 2005
Location: Atlanta, GA
Distribution: Debian, Fedora
Posts: 35

Original Poster
Rep: Reputation: 0
in case anyone else has this problem, the command "setterm -powerdown 0 -blank 0" worked. i am trying to figure out how to execute this command on startup. i'm confused because i see so many different ways to do this. if i just add "setterm -powerdown 0 -blank 0" to /etc/rc.local and /etc/init.d/rc.local, should that do the trick?
 
Old 07-14-2011, 03:16 AM   #10
nooneknowme
Member
 
Registered: Feb 2008
Location: Bangalore, India
Posts: 69

Rep: Reputation: 5
Quote:
Originally Posted by bloody_maiden View Post
in case anyone else has this problem, the command "setterm -powerdown 0 -blank 0" worked. i am trying to figure out how to execute this command on startup. i'm confused because i see so many different ways to do this. if i just add "setterm -powerdown 0 -blank 0" to /etc/rc.local and /etc/init.d/rc.local, should that do the trick?

Yes .. adding it to the rc.local file should do the trick.
 
Old 07-14-2011, 05:41 AM   #11
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,074

Rep: Reputation: 386Reputation: 386Reputation: 386Reputation: 386
You could as well recompile your kernel with all the acpi stuff disabled. Or, pass acpi=off to your kernel via the boot loader, I suppose.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't change display settings majikman MEPIS 5 06-02-2005 02:42 AM
how to change display settings satusred Linux - Newbie 2 11-03-2003 06:30 PM
Change display settings twangky Linux - Newbie 7 10-17-2002 10:11 AM
Can't change the display settings for X! phlame Linux - General 1 10-02-2002 12:40 PM
cant change any display settings on the fly. this Linux - Newbie 0 12-14-2001 08:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration