-   Linux - Newbie (
-   -   Centos Not restarting (

scandog 11-15-2005 11:08 AM

Centos Not restarting

I am farly new to linux and have purchased a couple of computer to setup as servers. each is identical and uses the following

Asus p5s800-vm Motherboard
160Gig HD
512Meg Ram
On board video
On board sound

The problem I have is I have installed Centos 4.1 and 4.2 (tried them both)
but when you go to restart system it will hang on Restarting after it has shut down all services.

I am new to this but I have never had any flavor of linux that has had this problem.

Also if I go shutdown it won't do that either never shuts off.

I have tried from the command prompt with shutdown -r now. and that doesn't work either.

I have turned of apci in the bios and onboard sound etc.

I have tried to add apic=off and apci=off to the grub file but that didn't work either. I am not sure if I did it right. I just added it at the end of the kernal line.

I am desperate for help on this.

Please can someone help me. These servers will need to be used remotley and I am sure I will need to restart them now and again.


beeblequix 11-15-2005 11:44 AM

1) make sure you have the latest BIOS. If needed head over to and find a newer BIOS
2) make sure the "etc" that you've turned off also includes legacy USB
3) try a different power supply.
4) if available on your board, enable "spread spectrum" on the cpu and memory.
5) you may try upping the voltage on the memory just a *tad*. btw, what type of memory are you using?

I actually had something very very similar on one of my Linux setups (I think it was my intel based MSI board). Somehow I got it resolved. (my system also didn't completely shut down, but I changed/installed something and now it will). I actually think you may want acpi on. I'd disable APM though. These are just ideas and I hope one of them helps.

scandog 11-15-2005 01:47 PM


I have tried what you suggested and still I am having no luck.

I have upgraded to the latest bios
turned on acpi and apic (bios and system)
I have disabled legacy usb
I tried a different powersupply.

I couldn't find anything for spectrum for the ran, or how to up the voltage.

I am not sure how to turn on apm it does show up on the list when booting as loading the deamon.

I am sure it is just a simple change in the kernel or something but I am stumped.

Thanks for any help

scandog 11-16-2005 12:01 PM

Please does anyone have any ideas about this problem!!

anti.corp 11-16-2005 01:04 PM

Hmm maybe it's the ram. Do you use different types of ram? Or maybe just different brands?

Would it be possible for you to try it with your on-board video turned off? (maybe you have some old agp card to install instead).

What about your netadapter, what type is it? Iv'e heard about problems with some older inteladapters.

Oh well you probably allready tryed this, but I just wanted to throw in what I had in mind.

Good luck.


scandog 11-16-2005 05:24 PM

The ram is new Kingston ram 512meg ddr I don't remember the speed. What ever is required for a 2.66Ghz P4. The netcard is on board. I will try a different video card and network card. I do have some of those. At this point I will try anything. Else I will have to go out and buy new mother boards for these servers. My boss won't like that.


All times are GMT -5. The time now is 10:14 PM.