LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-06-2012, 12:32 PM   #1
Zeno McDohl
Member
 
Registered: Apr 2005
Location: Saratoga, NY
Distribution: Slackware
Posts: 317

Rep: Reputation: 30
CentOS: command not linked/working


Recently installed CentOS and many commands are not working:
Quote:
[root@zrebirth zeno]# quotacheck
bash: quotacheck: command not found
[root@zrebirth zeno]# adduser
bash: adduser: command not found
[root@zrebirth zeno]# warnquota
bash: warnquota: command not found
[root@zrebirth zeno]# edquota
bash: edquota: command not found
But they all exist, so they must not be linked:

/sbin/quotacheck
/usr/sbin/adduser
/usr/sbin/warnquota
/usr/sbin/edquota

I'm sure there are more. Is there a way I can quickly fix all of these (even the ones I don't know) without doing each one manually?
 
Old 01-06-2012, 12:41 PM   #2
honeybadger
Member
 
Registered: Aug 2007
Location: India
Distribution: Slackware (mainly) and then a lot of others...
Posts: 855

Rep: Reputation: Disabled
'ldconfig' to link all the commands as root but all these commands not working is really odd.
 
Old 01-06-2012, 01:48 PM   #3
Zeno McDohl
Member
 
Registered: Apr 2005
Location: Saratoga, NY
Distribution: Slackware
Posts: 317

Original Poster
Rep: Reputation: 30
ldconfig command didn't work either, but found it under /sbin/ldconfig

So I ran that but didn't fix any.
 
Old 01-06-2012, 01:56 PM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,735

Rep: Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317Reputation: 3317
When you do su, /sbin/ , /usr/sbin/ are not in your PATH.

Then the command is not e.g. 'adduser' but '/usr/sbin/adduser'.


If you want /sbin/, /usr/sbin/ in the PATH :
Type 'su -' ( su <space> <hyphen> )

.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
The additional features for working with linked tables have been deactivated. j.smith1981 Linux - Server 2 02-26-2010 04:42 AM
CentOS 5.3 - PHP - ftp_connect working command line only Orayi Red Hat 7 12-22-2009 11:06 AM
Linked stylesheets not working in Apache... do I need to enable them? Robhogg Linux - Software 2 05-28-2006 07:25 AM
create linked file by command ,how ? silvercloud General 1 09-07-2005 08:38 AM
Winxp linked to Linux Linked to home network OverboardKiller Linux - Networking 2 06-09-2003 10:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration