-   Linux - Newbie (
-   -   centos 6.3 booting issue/errors (

tarangdawer 11-14-2012 12:56 AM

centos 6.3 booting issue/errors
hi i m pretty much new to linux.

os- centos 6.3

i updated the system, fine and restarted it.
it failed to start up.
then i did a fsck(on mounted filesystem, now i regret though)

now it shows the folowing errors ,

1. mount : you must specify the filesystem type.

2. kernel panic : not syncing , Attempted to Kill init
pid: 1, comm , init not tainted #(version number)


switching to text mode..

it hangs there. not when i specify rdshell as a parameter in kernel , from the grub loader , i drop into dracut shell. but commands like fsck etc , are not recognised there.

in /etc the file fstab is also missing. i tried creating it , similar to mstab, but of no use, it gets removed after the restart.

please help me out.

malekmustaq 11-14-2012 01:26 AM

Have you tried booting it from CD/DVD and run fsck to the drive not being mounted. Plain fsck without using a switch and just go through it with 'yes'. It worked for me, though I don't make any guaranty to yours. Nevertheless the partitions is quite broken it's worth a try.


John VV 11-14-2012 01:54 AM

there was a recent update the had a bug on editing the menu.lis for a new kernel
can you use an old kernel
during the 3 sec countdown select the previous kernel to boot from
( hit enter then use the down arrow to highlight the previous kernel
hit enter to boot from that one )

read your /boot/grub/menu.lis file

compare the top boot line with with the one you are NOW booted into

is there a blank entry for " root = " then nothing ( there should be a uuid in that empty spot)

if so
copy the old root=????? to the new line

tarangdawer 11-14-2012 04:21 AM

same problem with the old kernels..

All times are GMT -5. The time now is 12:01 PM.