LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Centos 5 clustering (https://www.linuxquestions.org/questions/linux-newbie-8/centos-5-clustering-4175411005/)

nishamcp 06-12-2012 07:13 AM

Centos 5 clustering
 
Hi,

I am new to clustering services and i am trying to implement a two node cluster in my environment over here. I have two centos 5 virtual machines with same configuration. I have created a file in /etc/cluster/cluster.conf following the guide http://docs.redhat.com/docs/en-US/Re...wo-node-cli-CA

After creating a sample file on the first machine i tried to validate the configuration using the command ccs_config_validate which returns command not found.

Tried to start the cman service using service cman start and it returns with the below mentioned error

cman not started. cant find local node name in cluster.conf /usr/sbin/cman_tool: aisexec daemon didnt start.

tried starting aisexec service but that too shows up cman not started.

Please help

acid_kewpie 06-12-2012 07:14 AM

that sounds like a pretty clear error there.... IS the node name in cluster.conf??

nishamcp 06-12-2012 07:24 AM

Hi Chris,

Please have a look at my cluster configuration file

<cluster name="mycluster" config_version="2">
<cman two_node="1" expected_votes="1"/>
<clusternodes>
<clusternode name="centos1.lab.com" nodeid="1">
<fence>
</fence>
<clusternode name="centos2.lab.com" nodeid="2">
<fence>
</fence>
</clusternode>
</clusternodes>
<fencedevices>
</fencedevices>
<rm>
</rm>
</cluster>

acid_kewpie 06-12-2012 08:13 AM

ok. I've looked. Now what?

Is one of those the correct name? It presumably needs to resolve in DNS somehow.


All times are GMT -5. The time now is 03:56 AM.