LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   CENTOS 3.9 Server can see localhost and DNS Name but not IP Address (https://www.linuxquestions.org/questions/linux-newbie-8/centos-3-9-server-can-see-localhost-and-dns-name-but-not-ip-address-621094/)

derekolive 02-14-2008 10:35 AM

CENTOS 3.9 Server can see localhost and DNS Name but not IP Address
 
I have just installed CENTOS 3.9 apparently succesfully.

I appear to have vsftpd and telnet "on" after doing some config stuff.

I can ping out from the server to other servers so am definately on the network.

I can ping localhost and full DNS name from the server itself but NOT the IP address of the server itself.

I can not ping, telnet or ftp to the server from elsewhere using either DNS name or IP address.

Any ideas please?

kstan 02-14-2008 11:04 AM

have you configure any firewall?
This problem is quite odd, since you can ping yourself with your domain name.
This server is just setup or used for long time?

derekolive 02-14-2008 11:19 AM

Brand New Installation - No Firewall
 
As the title suggests... I have only just completed the installation from a CD created off the WEB a few days ago. I purposely did NOT activate a firewall during the installation - there was an option to do so.

I agree it is a bit strange, and hence my question on the forum!!

I will probably try another install from scratch, but this is already my second install with the same issue occuring. I just wondered whether I needed to do anything in any of the networking config files that I was unaware of.

derekolive 02-14-2008 11:52 AM

Partly Solved!!
 
OK - I found some stuff about network configuration and started to look at ifconfig and the /etc/sysconfig/network-scripts/ifcfg-eth0 file.

What was wierd was that ifconfig reported the IP address incorrectly, but the ifcfg-eth0 file had the correct value.

I used ifconfig -a x.x.x.x to try and set the correct IP address and BINGO!! I can now ping the server both with DNS name and IP address.

I had to add a user in /etc/passwd in order to ftp succesfully ( root would not work ).

telnet connects to the login screen OK but I can't login as root or as the user I added. I'll keep digging on this one unless anybody has the answer before me!!

derekolive 02-14-2008 12:11 PM

Solved
 
I decided to use sshd instead of telnet - every body says one should do this anway - and connecting via a sshd client worked first time so I can now remotely connect and ftp.

I love it when a plan comes together!!


All times are GMT -5. The time now is 03:45 PM.