LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2004, 07:25 PM   #1
joshfields
LQ Newbie
 
Registered: May 2004
Posts: 16

Rep: Reputation: 0
Cdrom mounting problems


I'm using mandrake 10.

I had kernel 2.6.3 and everything was great.

I compiled and loaded kernel 2.6.6

Now, when I type mount /mnt/cdrom, if get an error about wrong fs or bad option or bad superblock.

If I type mount -t iso9660 /dev/hdc /dev/cdrom it works.

I need to be able to use mount /mnt/cdrom like I did before the upgrade.
 
Old 05-18-2004, 07:59 PM   #2
gkneller
LQ Newbie
 
Registered: Jan 2004
Location: UK
Distribution: Slackware & Debian
Posts: 27

Rep: Reputation: 15
The file that deals with that stuff is /etc/fstab. Read it, see if anything seems wrong. Try 'man fstab' for an explanation of what the different fields are for.
 
Old 05-18-2004, 09:35 PM   #3
joshfields
LQ Newbie
 
Registered: May 2004
Posts: 16

Original Poster
Rep: Reputation: 0
Here is the current fstab file:

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto user,unhide,umask=0,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

Any ideas?

Last edited by joshfields; 05-18-2004 at 09:37 PM.
 
Old 05-19-2004, 09:54 AM   #4
Kristian2
Member
 
Registered: May 2004
Location: Netherlands
Distribution: Slackware 13
Posts: 97

Rep: Reputation: 15
This is the line in my fstab file

/dev/cdrom /mnt/cdrom iso9660 noauto,owner,user 0 0

hope it helps.

Kristian
 
Old 05-22-2004, 03:13 AM   #5
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 857

Rep: Reputation: 110Reputation: 110
Way to go, Kristian! That line fixed the problem for me.

--Dane
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems mounting cdrom stonehurstX11 Linux - Newbie 2 12-11-2003 09:36 PM
cdrom mounting problems mep]-[isto Linux - Newbie 4 11-25-2003 04:51 PM
cdrom mounting problems fractal_chaos Linux - Hardware 5 08-13-2003 02:14 PM
problems mounting cdrom suse 7.3 toorar Linux - General 4 02-14-2002 07:46 AM
CDROM mounting Problems Road Linux - General 3 02-12-2002 06:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration