LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-10-2004, 05:50 PM   #1
gervin
Member
 
Registered: Dec 2003
Location: outback, australia
Posts: 40

Rep: Reputation: 15
Cdrom Mount Problem on Laptop


ugh. i had my cdrom drive working fine..now, i don't know what is up. i have an old nec versa sx machine that has the swappable floppy and cdrom drives. i use mandrake 9.1

i insert a cdrom...change to su...cd /mnt....mount cdrom....cd /cdrom...i get this:

bash: cd: cdrom/ Input/output error


in /etc/fstab i see:

/mnt/cdrom supermount dev=dev/hdc,fs=ext2,ro,--,iocharset=iso8859

/mnt/floppy supermount dev=/dev/fd0,fs=auto,--,icocharset=iso8859

i seem to recall that actually the floppy and cdrom drive shared /dev/fd0, since they ar swappable, but since i am so new at this, i do really know.

everything was fine until i had gone into mandrake control center to mount points to set super user mode, as was suggested to me. i didin't think i actually changed anything...

also, when i go to file manager in gnome and try to access /mnt/cdrom the window freezes up and i have to log out of gnome. weird.

since my hard drive is so tiny on this machine, i have a bunch of files on cd-rws, which now i cannot access.

any help is greatly appreciated!

thank you,

jxl
 
Old 01-10-2004, 06:03 PM   #2
KDE4me
Member
 
Registered: Apr 2003
Location: Australia
Distribution: RedHat 9.0 / Slackware 9.0/ FreeBSD 4.8 / Solaris 8 x86 / Mandrake 9.0
Posts: 90

Rep: Reputation: 15
I believe supermount prevents you from remounting devices. I think you have to go through removable media on the desktop. I don't know if this has helped. I'd also check if the permissions on the mountpoint are okay.
 
Old 01-10-2004, 06:07 PM   #3
gervin
Member
 
Registered: Dec 2003
Location: outback, australia
Posts: 40

Original Poster
Rep: Reputation: 15
sorry, i do not understand what you are saying! :-)

"I think you have to go through removable media on the desktop." not sure what that means...

i also do not know how to check permissions on mount points.

thanks.
 
Old 01-10-2004, 06:16 PM   #4
KDE4me
Member
 
Registered: Apr 2003
Location: Australia
Distribution: RedHat 9.0 / Slackware 9.0/ FreeBSD 4.8 / Solaris 8 x86 / Mandrake 9.0
Posts: 90

Rep: Reputation: 15
I believe somewhere on the desktop there is something like "my computer" click that then go to "removable media" then the media you want, I think supermount prevents certain access. If you wanted to check the permissions try looking at the manpages for: ls (option -l), chmod
 
Old 01-10-2004, 06:33 PM   #5
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
sry for referring you to the mandrake control panel, but i will let my conscience sleep (for now)...

go to the mandrake control panel, go to mount options or whatever the tool for mounting is, and find a place to disable supermount

if that does not work, we can try to help you setup a new fstab without supermount
 
Old 01-11-2004, 05:29 PM   #6
gervin
Member
 
Registered: Dec 2003
Location: outback, australia
Posts: 40

Original Poster
Rep: Reputation: 15
thanks. i disabled supermount, to no avail! can you help me get this fixed? i would be much appreciative.

jxl
 
Old 01-11-2004, 06:11 PM   #7
gervin
Member
 
Registered: Dec 2003
Location: outback, australia
Posts: 40

Original Poster
Rep: Reputation: 15
oops. and i get a new error message:

mount: wrong fs type, bad option, bad superblock on /dev/hdc. or too many mounted filesystems

yikes. i think it may be possible that the latter is the case, as i recall mounting dics, but forgetting to unmount. and at one point i got a message saying there were multiple mounts. don't know if this helps, but thought i'd add this.

and, on boot up i get this:

Mounting local filesystems: mount: /dev/hdc does not exist
/dev/fd0: Input/output error
mount: block device /dev/fd0 is write-protected, mounting read-only
/dev/fd0: Input-output error
mount: you must specify the filesystem type

now, if i remember correctly (um) since both the floppy and the cdrom drive share the same slot on this laptop, i think they are both supposed to live at /dev/fd0, fwiw.


jxl
 
Old 01-15-2004, 11:54 PM   #8
KDE4me
Member
 
Registered: Apr 2003
Location: Australia
Distribution: RedHat 9.0 / Slackware 9.0/ FreeBSD 4.8 / Solaris 8 x86 / Mandrake 9.0
Posts: 90

Rep: Reputation: 15
Sorry for saying this, but you might have better luck by reposting this thread in the Mandrake forum. Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cdrom mount problem suguname Mandriva 4 01-28-2005 02:34 AM
CDROM mount? problem ruse Mandriva 3 09-20-2004 05:10 PM
CDROM mount problems with MDK 10.0 Official on a IBM T30 laptop narikui Mandriva 5 07-20-2004 04:14 AM
CDROM Mount Problem grover77 Linux - Newbie 13 07-01-2004 01:35 PM
Mount CDROM problem KMcD Slackware 4 02-17-2004 08:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration