LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-27-2008, 08:02 PM   #1
wdave58
Member
 
Registered: Aug 2006
Location: Richardson, TX
Distribution: Slackware 12.0
Posts: 63

Rep: Reputation: 15
cdrom in fstab but not seen in konqueror


/dev/hda2 swap swap defaults 0 0
/dev/hda1 / reiserfs defaults 1 1
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
/dev/sda1 /mnt/usb auto defaults 0 0

ok ,,, here is my fstab ,,,, everything should be ok right ????
well,,,, konqueror will NOT see the hda1 or the cdrom ....
these were auto detected and written into fstab by ,,, is it mtab???
anyway,,, i assumed i needed to just mount them so i went to the shell
and typed mount -a,,,,, well ,, no luck ...
i've read in some of the posts something about sym lynks and also a iso19660 in place of auto for the cdrom part but i am a little hesisitant to make the changes without some advice ...
and hda1 does show up just says the same thing my usb drive said but was cleared up when i added the /dev/sda1 line and mount -a in shell for the usb but the hda1 line pre-existed all of that and mount -a does not bring it up in knoqueror
so,,, if there is anyone out there on a sunday evening ..... i need your help ...
thanks,
david
 
Old 04-27-2008, 08:09 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Linux Mint 17, Debian 8
Posts: 7,863

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
The command should be:

mount -t iso9660 /dev/cdrom /mnt/cdrom

----------------
Steve Stites
 
Old 04-27-2008, 08:11 PM   #3
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
I may be wrong but konqueror will not show the cd rom if there is no data cd in the drive. If I read it right you got your hda1 straightened out.

jailbait am I right or will the drive show without a cd.

Last edited by Larry Webb; 04-27-2008 at 08:13 PM.
 
Old 04-27-2008, 09:22 PM   #4
wdave58
Member
 
Registered: Aug 2006
Location: Richardson, TX
Distribution: Slackware 12.0
Posts: 63

Original Poster
Rep: Reputation: 15
mkdir / ?????

ok,,,, sorry it took so long to get back ,,,, i hope you are still out there ...
took "auto" out of fstab and inserted "iso9660" ...
that did not work
took "noauto, owner, ro" out and put defaults ....
that worked, but no media so you were right ,,, put in a cd i just burned and viola after mount -a the cd drive showed up in konqueror and i was able to open it ...
the thing about the hda1 is the same though ....
it shows up in knoqueror but i am NOT able to access it
this is how it looks in fstab
/dev/hda1 / reiserfs defaults 1 1
this is a new installation ... (yesterday) ... should i mkdir / ????
is that even possible or is mkdir for externals only ????
david
 
Old 04-28-2008, 02:00 AM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Err, if you're running Linux then your root partition (i.e. /dev/hda1) is already mounted on /. Do you get any error messages when you try to access your /dev/hda1 via Konqueror? If so, it'd be in your interests to post them.

Also, for external disks, you shouldn't really add entries like "/dev/sda1" to your fstab, because those devices aren't guaranteed to be called the same thing (/dev/sda in this case) by the kernel all the time. It's better to use udev (see this for more info).
 
Old 04-28-2008, 04:48 PM   #6
wdave58
Member
 
Registered: Aug 2006
Location: Richardson, TX
Distribution: Slackware 12.0
Posts: 63

Original Poster
Rep: Reputation: 15
the "/" thing with security policy?

thanks for the reply as to the / thing ...
just wondered how i could be logged in as root and get:

A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)" destination "org.freedesktop.Hal")

this is the same thing i would get until i learned how to edit fstab for the usb flash drive .....
and for that matter the cd-rom will show it when there is media in the drive but not properly set up in fstab ...

this is slackware 12.0 and
linux kernel 2.6.21 using
kde as file manager
 
Old 04-28-2008, 05:01 PM   #7
Ace Blackwell
Member
 
Registered: Mar 2004
Location: Kentucky, USA
Distribution: SlamD 12.1 / Slack 12.0 ~ 14.2_64
Posts: 307

Rep: Reputation: 41
Slack 12

I have had the same issue. Konoquer would see the drive but gives me permission denied. It also give me some grief about not being mounted. Even thought everything else says it is. Here are some options. It won't solve the HAL problem but will allow you access to the files.

1) In shell use MC (Midnight commander)
2) In KDE use Thunar File Manager
3) In Konquer, click to the left side on Home and then click on the up arrow key at the top of the Konquer window. This will allow you to move all the way up to / directory and then you can click the folders to move back down into the directories.

Also, if you found a solution to the HAL problem, let me know

Ace
 
Old 04-28-2008, 09:05 PM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,899
Blog Entries: 27

Rep: Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185Reputation: 2185
Hi,

Be sure your user is in the following groups;
Code:
floppy audio video cdrom plugdev
.

The 'plugdev' is important to allow the user to work with 'HAL'.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Konqueror won't open if i put sda on the fstab LinuxFanPhilippines Linux - Newbie 3 11-27-2006 04:39 AM
fstab noauto - konqueror overides this? stumbling_hack Linux - General 1 09-22-2004 05:53 PM
fstab cdrom help eo697 Slackware 24 07-26-2004 10:14 AM
cdrom not in fstab GlobShim Linux - General 8 04-02-2004 10:41 PM
fstab and cdrom links - hdc or cdrom? tunedLow Linux - Newbie 5 12-21-2001 01:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration