-   Linux - Newbie (
-   -   cd-rom drive working in knoppix Hard drive installation (

dj_dubbbz 02-29-2004 05:11 PM

cd-rom drive working in knoppix Hard drive installation
Okay, I downloaded Knoppix, I booted it up from CD. Everything worked fine. In fact, I loved it so much that i decided to install it to the hard drive of one of my old windoze boxes. I the spent 2 hours formatting and reformatting my hard drive(had a few difficulties :D), only to find that once I booted from my hard drive, my cd-rom, and floppy drive won't work. It says: Unable to run the specified command. The file or directory "file:mnt\cd-rom" does not exist.

Could someone please help me. I know not a thing about Linux, I barely know the difference between a kernel, and a and a tar file.

dj_dubbbz 02-29-2004 11:21 PM

could someone please help me, I'm desperate:( :confused:

toastermaker 03-01-2004 09:04 AM

Until someone who knows thier stuff can get to you:
I have an older version of knoppix, it has a gui app called "kwikdisk" in the default kde desktop. It is for mounting things. You could look for that in the menus.

The people who know thier stuff will tell you to try to mount the cdrom.
If you search these forums for the word "mount" you will find some things to try, like I said untill someone who knows thier stuff gets to you.

dj_dubbbz 03-01-2004 09:07 PM

It will not let me mount etheir drive, I have tried all the ways I can think of to mount it(which aren't many), but nothing seems to work. Thanks, anyway toasermaker;).

pb&j 03-02-2004 11:52 AM

hey man did you try being root to do stuff?

aaa 03-02-2004 11:58 AM

Linux accesses devices by mounting them to a directory. It looks like the directories for the cdrom and floppy don't exist where knoppix expected them to be. Try 'mkdir /mnt/cdrom' and 'mkdir /mnt/floppy'. I don't think you need to be root in knoppix to do this stuff, but in case you need it, use 'su -' to switch to root (no password needed).

All times are GMT -5. The time now is 06:24 PM.