LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-06-2005, 12:25 PM   #1
TaNeK
Member
 
Registered: Dec 2004
Posts: 59

Rep: Reputation: 15
CD mount?


Hello

When waiting for my downloads to get ready and my concentration to get back, so I can compile a new kernel, I decided to install warcraft 3 from my CD. The problem is that linux cant seem to find my cd-drives at all... /media/cdrom /media/cdrom0 and /media/cdrom1 are all empty, no matter what discs I insert.

My /etc/fstab

Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>     <dump>  <pass>
proc            /proc           proc    defaults      	0       0
/dev/hdc3       /               ext3    defaults,errors=remount-ro 0       1
/dev/hdc2       none            swap    sw              0       0
/dev/hda        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/hdb        /media/cdrom1   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/hdc1	/windows	ntfs	defaults	0	0
/dev/hdd5	/hdd1		ntfs	defaults	0	0
/dev/hdd6	/hdd2		vfat	umask=0,iocharset=iso8859-1,codepage=850,quiet,user	0	0
none 		/sys 		sysfs 	defaults 	0 	0
 
Old 01-06-2005, 12:42 PM   #2
PBSchmidt
Member
 
Registered: Aug 2004
Location: Aachen, Germany
Distribution: Debian Sarge
Posts: 129

Rep: Reputation: 15
Did you try to mount manually?
Code:
$ mount /dev/hda
Though, hda as a cdrom is strange...

Maybe the cdfs / isofs is not in your current kernel, try to insmod it.

HTH,

Peter
 
Old 01-06-2005, 12:45 PM   #3
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
Talking

I do not want to spoil you......Aaaaa....never mind.
Evil chmodding always helps
$su
$chmod 666 /dev/hda*
$chmod 666 /dev/hdb*
Then mount
 
Old 01-06-2005, 01:08 PM   #4
TaNeK
Member
 
Registered: Dec 2004
Posts: 59

Original Poster
Rep: Reputation: 15
I've found it kind of wierd too, that hda and hdb are my cdroms, but I've never had any problems with having my hard drives as hdc and hdd, so I never cared. Ill try your ideas!
 
Old 01-06-2005, 01:16 PM   #5
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
The idea is not to use cdrom as a Primary Master. C'est tout
 
Old 01-06-2005, 01:19 PM   #6
TaNeK
Member
 
Registered: Dec 2004
Posts: 59

Original Poster
Rep: Reputation: 15
Trying to mount manually gives:

Wrong fs type, bad option, bad superblock on /dev/hda, or too many mounted filesystems.

Fs type should be correct, superblock says nothing to me, and I have no idea of how many filesystems is the maximum to mount

hdb on the other hand seem to have mounted OK... :S

hda is a DVD-drive, maybe that's why? another fs perhaps?
 
Old 01-06-2005, 01:23 PM   #7
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
After you've changed your fstab don't forget to
#su
#mount -a
 
Old 01-06-2005, 01:29 PM   #8
TaNeK
Member
 
Registered: Dec 2004
Posts: 59

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by SlackerLX
The idea is not to use cdrom as a Primary Master. C'est tout
Perhaps it's not a good idea to have a cd-drive as prim master, and my BIOS says my prim master is my hard drive. very spooky :S
 
Old 01-06-2005, 08:14 PM   #9
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
what does dmesg say?
 
Old 01-07-2005, 08:52 AM   #10
TaNeK
Member
 
Registered: Dec 2004
Posts: 59

Original Poster
Rep: Reputation: 15
it all worked now, probably something wrong with my disc in /dev/hda :S thanks all!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to give not-root user ability to mount devices to any mount point??? jdupre Linux - General 8 02-04-2012 11:03 AM
NFS mount of smb mount of windows share: permission denied problem :( Bagatur Linux - Networking 4 07-07-2009 12:34 PM
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 08:29 PM
can mount C not D FAT: invalid media value (0x45) mount: wrong fs type, bad option Emmanuel_uk Linux - Newbie 10 11-29-2005 03:47 AM
automount: mount(generic): failed to mount (null) (type iso9660) on /mnt/media/ vasudevadas Slackware 5 10-17-2005 04:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration