-   Linux - Newbie (
-   -   catalina.out has binary data after rotate (

TDCornwell 02-14-2011 12:54 PM

catalina.out has binary data after rotate
Apologies if this is a tomcat question, but it seems like it might be something else...

I manually rotated my catalina.out file, and now the file jumps to 30+Mb and when I try to view it, less tells me it might be a binary file. It sure appears to have binary data in it, about 30meg of it.

I did the rotate via a copy:
copy catalina.out to another file
cat /dev/null > catalina.out

I have tried using echo:
echo "" > catalina.out
...also with the same result.

This application isn't something I can just bounce when necessary. It kind of appears that the original file is still there - sort of. But is it not readable text anymore.

Thanks in advance,

SunOS 5.10
tomcat 5.5.26 (version required by app vendor)

kbp 02-14-2011 03:55 PM

Do you have swallowOutput set ?

TDCornwell 02-15-2011 12:38 PM

Thanks for the speedy reply!

No I don't have swallowOutput set, and, after a bit more investigation, I think I see that this is an issue with tomcat logging in general, but that there are solutions.

I am dealing with a vendor-supplied tomcat installation, and have only a little control over the configuration. Perhaps I can fix this from within tomcat, perhaps not. :P

All times are GMT -5. The time now is 12:20 PM.