LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   can't turn off screensaver... (https://www.linuxquestions.org/questions/linux-newbie-8/cant-turn-off-screensaver-258225/)

Rarrum 11-23-2004 01:56 AM

can't turn off screensaver...
 
I'm having a problem with the linux screensaver or power-saver-thing... I can't seem to turn it off. The monitor turns itself off after about 10 minutes of me not using the computer, which is really annoying as I often watch stuff on that computer while working on another computer.

I'm running debian. When I go to the menu and choose "Screensaver Preferances", it starts up and says:

Warning:
The XScreenSaver daemon doesn't seem to be running on display ":0.0". Launch it now?

So I hit OK to do that, and I get:

Error:

The xscreensaver daemon did not start properly. ...(some annoying warnings saying I'm running as root, which I do just so I can edit the files on my own computer reasonably)... Try running this command:
xhost +localhost

... so I type that command, and it appears to work.. but when I choose to restart the daemon, I get the same Error ("The xscreensaver daemon did not start properly...").

I'm not really interested in running a screensaver, mainly I just want to adjust the time so it won't turn off the monitor so soon... changing it to like 1 hour would be preferred... or if needed totally disabling it's ability to turn it off is fine too.

Supermarine9 11-23-2004 03:20 AM

It sounds to me the trouble your having isn't so much the screen saver as it is the energy start compliant stuff. Are you sure it is in the screen saver control console to disable or change your power management settings. Normally you change those setting under a power manager console 'of type' or within the BIOS itself.

As far as running as 'root' for ease of use sake or not - very discouraged and just not a very good idea!

Rarrum 11-23-2004 03:54 AM

I'm really not sure where it is in linux to adjust the power management stuff like that. I'd used windows for a long time, and you could get to it from the screen saver area there.

In the "Advanced" tab in the screen saver preferances..
I set the "standby/suspend/off after" times all to 60 minutes... but it didn't seem to do anything. Thats why I'm thinking the previous errors I was getting might be related.

Draygo 11-23-2004 06:24 AM

My quick work around is to open a term and type

xset -dpms
xset s off


This in effect turns off the dynamic power managemnt and screensaver. Bad thiing is I always have to do it everytime i start X.

Rarrum 11-23-2004 11:08 PM

that seems to do the trick, thanks!

Genesee 11-23-2004 11:58 PM

Quote:

Originally posted by Draygo
This in effect turns off the dynamic power managemnt and screensaver. Bad thiing is I always have to do it everytime i start X.
why not just put it in .xintrc/.xsession?


scroll down to 9.4:
http://www.debian.org/doc/manuals/re...h-tune.en.html


All times are GMT -5. The time now is 05:51 PM.