LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't stop X Server (https://www.linuxquestions.org/questions/linux-newbie-8/cant-stop-x-server-475410/)

jrmints 08-19-2006 12:29 PM

Can't stop X Server
 
I have been trying to download an Nvidia driver, but I keeping getting the error message that I need to end X Server. How do I do this?

AzrielMacKay 08-19-2006 02:17 PM

Well if you aren't running a display manager you can just hit cntl-alt-backspace. If you are running kdm or gdm though you can do /etc/init.d/kdm stop and then do the previous thing I mentioned (on debian based distros atleast, you didnt say what you're using)

dangerboy 08-19-2006 02:21 PM

If you can't log out of your X Session to a command prompt, open a console in X and type:
Code:

su
Enter your root password, then type:
Code:

init 3
This should kick X off and bring you to a command prompt. Make sure your NVIDIA*.run file is saved to a convenient location. I usually like '/home/user/' and make sure it is executable with
Code:

chmod +x NVIDIA*.run
Run it and you should be good to go.

jrmints 08-20-2006 02:07 PM

I'm running FC5, i tried the cntrl-alt-backspace, but I dont think that worked, any other ideas?

dangerboy 08-20-2006 05:52 PM

Out of curiousity... have you (jrmints) tried my suggestion above? If so, what results did you get?

jrmints 08-21-2006 05:13 PM

this is what happened

[jrmints@localhost ~]$ su
Password:
[root@localhost jrmints]# init 3
bash: init: command not found
[root@localhost jrmints]#

maybe it has to do with the distro?

arturhawkwing 08-21-2006 05:38 PM

What distro do you use? differant distros handle init differantly.

gilead 08-21-2006 06:49 PM

It could be that by using su instead of su -, you didn't get root's environment settings. Try it with su - or use the full path to init (or telinit) - /sbin/init or /sbin/telinit

dangerboy 08-21-2006 06:59 PM

After some Googling, I found a howto on NVIDIA drivers in FC. It recommends init 3. I think gilead is right, specific paths or 'su -' should do the trick. Here's the How To:

http://www.patheticcockroach.com/mpam4/index.php?p=36

It's for FC4 but unless FC5 is radically different, installation should be the same.

Let us know how it turns out.


All times are GMT -5. The time now is 11:37 AM.