LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   cant start team fortress 2 server upon bootup Cent OS 7.4 details inside (https://www.linuxquestions.org/questions/linux-newbie-8/cant-start-team-fortress-2-server-upon-bootup-cent-os-7-4-details-inside-4175614334/)

kd0 09-22-2017 07:26 PM

cant start team fortress 2 server upon bootup Cent OS 7.4 details inside
 
Code:

[root@server ~]# systemctl status tf2server.service -l
● tf2server.service - Team Fortress 2 server
  Loaded: loaded (/etc/systemd/system/tf2server.service; enabled; vendor preset: disabled)
  Active: failed (Result: exit-code) since Fri 2017-09-22 20:20:00 EDT; 4min 21s ago
 Main PID: 936 (code=exited, status=127)

Sep 22 20:19:59 server.coleshosting.com systemd[1]: Starting Team Fortress 2 server...
Sep 22 20:19:59 server.coleshosting.com sh[936]: /home/hlserver/tf.sh: line 2: tf2/srcds_run: No such file or directory
Sep 22 20:20:00 server.coleshosting.com systemd[1]: tf2server.service: main process exited, code=exited, status=127/n/a
Sep 22 20:20:00 server.coleshosting.com systemd[1]: Failed to start Team Fortress 2 server.
Sep 22 20:20:00 server.coleshosting.com systemd[1]: Unit tf2server.service entered failed state.
Sep 22 20:20:00 server.coleshosting.com systemd[1]: tf2server.service failed.

yet tf2/srcds_run exists! or should there be a forward slash infront of it or something? cause the .sh file looks like this

Code:

#!/bin/sh
tf2/srcds_run -console -game tf -nohltv +sv_pure 1 +map ctf_2fort +maxplayers 24

when im in the directory it runs fine like if i navigate to /home/hlserver and execute ./tf.sh it runs.. so what am i doing wrong here??

kd0 09-22-2017 08:13 PM

never mind i fixed it by adding /home/hlserver/tf2/srcds_run


All times are GMT -5. The time now is 10:37 AM.