LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't sh nvidia driver (https://www.linuxquestions.org/questions/linux-newbie-8/cant-sh-nvidia-driver-128457/)

Soulful93 12-23-2003 04:20 PM

Can't sh nvidia driver
 
I've been using the step by step on this site to install my nvidia drivers.

I changed my inittab file, changed vesa to nvidia. I've killed x and I'm at the command prompt.

When I issue ls as root I get

Desktop/ drakx/ nvidia-llinux-x86-1.0-4496-pkg2.run.txt/ tmp/ (in blue)

Now just by looking I can see that this isn't right, as it's giving me part of a directory output, but I tried anyway.

I tried exactly as above and it didn't work. So I thought maybe if I cd'd over to my Desktop directory nope. I tried to cd over to a directory similar to the Desktop / drakx/ dir and found nothing. The only directory ls works in is the root dir.

Here's exactly what I've done. I've downloaded the driver from Nvidia. Placed it on my local user Desktop (even though I had the keys in the taskbar it wouldn't let me move the file in my local account). I had to log in as root to edit the correct files. I don't know what the deal with that is, again I had the root keys in my taskbar but it wouldn't allow me to make any changes.

Anyhow, I rebooted and issued ls and the above problem started. Also will it effect my local user account if I issued the commands logged in under root?

Can anyone help?

Soulful93 12-23-2003 04:52 PM

Anybody?

mikshaw 12-23-2003 05:23 PM

I don't know what you're expecting to get from ls, but as far as I can tell, you got exactly what I'd expect.

'nvidia-llinux-x86-1.0-4496-pkg2.run.txt' looks wrong, though....it may not work if it was downloaded as a text file (i think it's supposed to be a binary?).

Try (as root, and without the txt extension):
./nvidia-llinux-x86-1.0-4496-pkg2.run
or
~/nvidia-llinux-x86-1.0-4496-pkg2.run

Soulful93 12-23-2003 05:37 PM

I've already tried that.

I downloaded the file from Windows which is probably the problem. When I clicked the download link it sent me to the actual code page. So I right clicked and did a save as.

Do you think this could be my problem?

Soulful93 12-23-2003 05:44 PM

Ok I've just ventured back to the NVIDIA page and checked the download it gives a run extension but when you right click in Windows under save as it says (save as text document). Oh man, now I remember why I'm switching to Linux.

Thanks that's really all I needed. I'm just going to go ahead and download the file again.

jschiwal 12-23-2003 05:53 PM

I don't think that it downloaded properly. That may not be the most recent driver also. Also, the install program will not run when x is running. It will look on the net for a more recent version, and may need to compile a driver interface for your kernel. You will want to make sure you have the kernel source installed. It will install a long document in /usr/local/doc/. I don't remember the exact name, but I think it's something like NVIDIA-GLX.doc It displays options you may need to use to get the newest source off the web. After installing, print out this document before editing your XF86config-4.

la7eralus 12-23-2003 11:27 PM

control + alt + f2
login as root
enter ur password
type telinit 3
make sure u had the driver in your root (home) folder
type:
sh "drivername" where drivername is the name of the driver (IT IS CASE SENSITIVE)
itll take u through the install
when alls done type
telinit 5
gl :D

Soulful93 12-23-2003 11:59 PM

Thanks!

I'm going to re-download right now. I'll make sure I post my method after I'm finished. :Pengy:

Soulful93 12-24-2003 02:53 AM

Ok, I got everything installed and when I startx, I get...

A white flash which I'm assuming is the NVIDIA logo and then a black screen. Any ideas?

Baldrick65 12-24-2003 07:22 AM

Are you sure that you edited your XF86config-4 file correctly before rebooting? IIRC, all you need to change is under the Section "Device", the Driver "nv" to Driver "nvidia" and you should be good to go.

Baldrick

qwijibow 12-24-2003 08:33 AM

if you get the nvidia logo, then you must have changed the CFree driver from nv to nvidia.

get into comand line, and issue the following command..

startx > ~/error1.log 1> error2.log 2> error3.log

and have a look at the generated error.log files, they will tell you why it didnt work.

ohh, and create a file in your come directory called .xinitrc with the command
touch ~/.xinitrc

then put xterm in it, with the command

echo "xterm" > ~/.xinitrc

now try to startx.

that should try to load a simple x terminal instead of a full DE.

Soulful93 12-24-2003 02:46 PM

Ok I'll try that. Yes I removed vesa and replaced it with nvidia. Under the other section I was supposed to edit none of the things that I was supposed to remove were there, so I didn't bother touching anything in that section of the xF86.

I also have read about a known issue with APIC (I believe). It sounded similar to my problem so I disabled that, and it still didn't work.

I was on another site and read that the default size settings can cause this issue, I haven't tried this but I'm going to try it later tonight, I'm going to set it to 800x600 and see if that takes me anywhere. I'll look at the error log's first though.

The weird thing is, is that it act's as if it installs flawlessly, but then nothing happens.

Soulful93 12-24-2003 06:47 PM

Ok, I just came back from Linux...

I got to command as it starts on 3 instead of 5, and realized that I didn't have one of the buttons to issue the above commands on my laptop keyboard. The squiggle after startx >.

I did however hit tab or shift by mistake and got a list of commands. I saw an xservererror command I entered it and it looked like it tried to load x and then I got a black screen I hit enter and got a list of things. The screen looked bad it was poorly lit and it looked like it had small lines down all of it.

When I got the command line back I entered KDE and it started and went black and I hit enter.

I got this. I wrote it by hand so it may not be formatted correctly but whatever.

>Warning: Symbol map for key <SPCE> redifined (a bunch of these for different keys on my keyboard, I figured one was sufficent)

>Using last definition for conflicting fields

Errors from xkbcomp are not fatal to xserver

Startkde: Starting up...
Kbuildsyscoca running...
Mcop warning: User defined signal handles found for SIG_PIPE overriding
Startkde: Shutting down
Klauncher: Exiting on signal 1
Startkde: Running shutdown scripts
Startdke: Done

Anyone know what might be going on?

jschiwal 12-29-2003 07:28 AM

You might want to show us your XF86config-4 file.

before, try as root running the installer like:

./nvidia-installer --update

This will check if there is a newer driver and install it.


All times are GMT -5. The time now is 05:24 PM.