LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   can't seem to get scsi-emulation working on RH9 (https://www.linuxquestions.org/questions/linux-newbie-8/cant-seem-to-get-scsi-emulation-working-on-rh9-82363/)

cjennings 08-15-2003 04:47 PM

can't seem to get scsi-emulation working on RH9
 
Hi everyone,

I've been trying to get scsi-emulation working on RH9 so I can use XCDRoast. I've been following some recommendations elsewhere on the web, but haven't found anything helpful. There was also a post here on how to get it done with Slackware, but since this system is different, the directions don't make sense on RH9.

Here's what I've done so far:
- added hdc=scsi to the end of the line:
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/
...in my grub.conf file
and rebooted.

- tried to find the rc.modules file so I could put
/sbin/modprobe ide-scsi
...in it. I couldn't find it so I tried to launch it manually. It gave me the following errors:

/lib/modules/2.4.20-8/kernel/drivers/scsi/ide-scsi.o: create_module: Operation not permitted
/lib/modules/2.4.20-8/kernel/drivers/scsi/ide-scsi.o: insmod /lib/modules/2.4.20-8/kernel/drivers/scsi/ide-scsi.o failed
/lib/modules/2.4.20-8/kernel/drivers/scsi/ide-scsi.o: insmod ide-scsi failed

Anyone have any helpful hints?

Thanks,

-- Craig

bulliver 08-15-2003 06:55 PM

You must be root to run modprobe.

cjennings 08-15-2003 08:00 PM

that's good. thanks! I should have thought of that. :)

However, where do I launch it from if I want it to start on boot?

Also, what do I link /dev/cdrom to? It appears there's no /dev/sr0 or /dev/sr1 (and shouldn't that be what I link a scsi device to)?

Any more help would be appreciated!

bulliver 08-16-2003 01:45 AM

you can put the command 'modprobe ide-scsi' in /etc/rc.local

putting 'alias /dev/cdrom ide-scsi' in modules.conf should work too.

You don't link /dev/cdrom to anything. You don't actually have a scsi device, you're just pretending so you can use the drivers for cd burning. Trying to access /dev/sdx will just cause an error.


All times are GMT -5. The time now is 03:02 PM.