-   Linux - Newbie (
-   -   Can't remote ssh into a CRUX linux machine (

emeak 08-10-2009 09:44 PM

Can't remote ssh into a CRUX linux machine
I'm relatively new to this whole forum thing and not very experienced with Linux. I hope my post is not too verbose.

I have a particular problem at the moment with trying to gain access to a machine which is part of a bigger system and is managed by the Company I work for. The system is designed by others. I/we do support on various windows and linux machines on this system. I hope that helps set the scene.

My ultimate aim to to run a custom X window application. Therefore, I first setup a ssh session, enable X11 port forwarding and start the custom app.

I'm using PuTTY (on windowsXP) from my office to access a remote linux (CRUX) kernel 2.4.XX machine. I login via a user called "fred" (with password fred). But everytime I try and login it rejects my login request. I'm sure I have the right password. Alternatively, I can succesfully login as "root" to the same machine.

If I ssh and login as "root" I can "su - fred" successfully. As "fred' user my X window app won't work (I'm using Cygwin/X for an X-server on Windows). Even if I try and start "xcalc" it doesn't work. I'm told X windows protocol doesn't handle NAT and firewalls very well that's why people use ssh and X11 port forwarding.

Incidently, I can start and X app (e.g like 'xcalc') when I'm logged in remotely as "root" so at least I know my X11 forwarding is setup properly.

I can also telnet to the CRUX machine from my windows machine successfully. However, when I do this no password is requested and I successfully connect to the machine??? I haven't tried running 'xcalc' to see if X will run over a telenet session? I don't think somehow it will!

This is strange to me as the local users (on-site) use the password "fred" to login locally as "fred" user.

I did a bit a search and found a post titled "root password isn working" which talks about a similar problem but with "root" user. There is some settings in sshd_config which did the trick...
Perhaps a tweak in sshd_config is required????

I'm stumped? Please help

Is there any log files I can look at?

Is it something to do with user accounts and passwords?

Does "sshd" require to be restarted in sshd_config is changed?

If so, what's the best way to do that without rebooting the machine?

Suppose another alternative is VNC bu I've had no experience in setting it up?

Hope it all clear. Thanks in advance

mono-factor 08-10-2009 09:52 PM

By the sounds of it you seem more advance in Linux than me (im a windows user) but putty normally uses port 22.
I don’t quite understand, are you able to make a connection to box? And then when you enter the password it says connection refused? (Or am I making some stupid mistake and i wasn’t reading your post correctly.)
Surprisingly i noticed that sometimes debian distro (gay ubuntu) don’t allow you to putty in as root, (well it happened for me).but rather just use the sudo command to do root stuff.

chrism01 08-10-2009 11:12 PM


putty normally uses port 22
Actually it uses whatever port you specify. Of course if you're using ssh it's (normally) 22, 23 for telnet and so on. See /etc/services on /*nix machines

All times are GMT -5. The time now is 10:29 PM.