LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't read lock file /tmp/.X0-lock (https://www.linuxquestions.org/questions/linux-newbie-8/cant-read-lock-file-tmp-x0-lock-204155/)

squinn 07-12-2004 01:39 PM

Can't read lock file /tmp/.X0-lock
 
I just installed redhat 7.1 (my first time installing Linux). After installing, Linux froze on me and after a restart, I am unable to get X running.

The error I get is the error in the subject:

Can't read lock file /tmp/.X0-lock

I tried removing the file but it won't let me.

Upon reboot, there is a message that says:" rm: cannot remove /tmp/.x0-lock': Operation not permitted."

... Then, "I cannot start teh X server. It is likely that it is not set up correctly. I view the output and it repeats the error with the lock file.

Any suggestions would be appreciated...
Thanks

Finlay 07-12-2004 07:46 PM

are you trying to remove the lock file with root?

squinn 07-13-2004 08:05 AM

Yes, I tried to remove the file from the root...

I tried reinstalling and now I get an error on disk 3 of the redhat installation:

the package tetex-xdvi-1.0.7-66 cannot be opened. This is due to a missing file or perhaps a corrupt package. If you are installing from CD media this usually means the CD media is corrupt or the CD drive is unable to read the media.

I am really stuck now...

lone_nut 07-13-2004 03:42 PM

Well you are not so stuck as you may thing. You can install red hat if the first cd works.

Second you are way to fast at reinstalling. The file you could not remove can only be deleted by the superuser (administator) wich is called root under GNU/Linux (because the username is root). Make sure you are looked in as root. now if you cant remove the file as root, some program is looking it. With good reson as it is a log file.

Why are you trying to install and old version of Red Hat? you most likely want fedore core 1 or 2 or at least Red Hat 9 (the last version before they decided to make on for enterpriess and one for personal use (note this is just the recomandation, there is nothing stopping you from useing fedore core in your company)

Last Wellcome to the free world.


All times are GMT -5. The time now is 01:42 PM.