-   Linux - Newbie (
-   -   Can't read audio cds in xmms !!! (

Anmar 09-09-2003 04:32 AM

Can't read audio cds in xmms !!!
I can't hear music in linux except my mp3s .

Never heard one of my cds in linux .

and there's another problem,,,,
I can't play anything in xmms till I run artscontrol program while playing .

I had me to put it in the startup area .

How to deal with these 2 problems ?

Anmar 09-09-2003 06:37 AM

I need help .

Azmeen 09-09-2003 06:51 AM

Right Cick XMMS
-> Options
-> Preference
-> Audio I/O Plugins tab and select CD Audio Player
-> Configure

Set your devices properly... only you will know this.

Anmar 09-09-2003 07:00 AM

Where can I find my devices ?

TheDewAddict 09-09-2003 09:18 AM

FYI, Linux does not do Digital Audio Extraction like Windows does. What this means is that you need a CD Audio cable connected internally from your CD-ROM to your sound card. There is a plugin available for XMMS, just search the forum for "XMMX CD audio" and you'll find it.

EDIT: Here's the post with the link:

Azmeen 09-09-2003 09:26 AM


Originally posted by Anmar
Where can I find my devices ?
Post the contents of your /etc/fstab file here...

In console, just type cat /etc/fstab
and we will be able to help you more after seeing it.

Anmar 09-09-2003 09:29 AM

What do you mean with posting the contents .

Anmar 09-09-2003 09:43 AM

I downloaded the file it has been installed very well .
How to set the device ?
Do we still need to connect that wire inside the box ?

Azmeen 09-09-2003 09:46 AM

Downloaded what file? The fstab is already on your system, I'll need to see what's in it to tell you how to set your CD device. So if you don't mind, please post what you see (copy and paste here) when running cat /etc/fstab.

Anmar 09-09-2003 10:06 AM

I don't understand the cat/etc/fstab thing you are all talking about .

TheDewAddict 09-09-2003 10:07 AM


Originally posted by Anmar
I downloaded the file it has been installed very well .
How to set the device ?
Do we still need to connect that wire inside the box ?

If you are talking about the plugin I linked, you only need that if your CD player has no wire inside the box. If you have that wire, this plugin is useless. I havent used it, so I can't tell you how to configure it.

Anmar 09-09-2003 10:14 AM

And the post you told me about,,,

They said that I have to connect somewires inside,
Do I have to,
About the file I was talking about,
It wasn't a file, It was a bunch of files compressed in a .tar file that I have to download as what they said in that post .
SO,,, I've downloaded that .tar file and installed the package,
forgot to say that it's a cdreading plug in,,, [sorry]

I saw the plug in in the plug ins area in xmms and tried to configure .
The questions is :
How to set the device in that configuration ?
an other question:
If the device setting is correct,,,,,Where to play my music ? (Where do I find my audio cd files?)

I'll be thanking .

Anmar 09-09-2003 10:17 AM

Sorry, We were posting at the same time .

Does anyone k'now how to check If I have that wire or I don't ?

Anmar 09-10-2003 12:47 AM

I need help,

Can anyone explaine to me what is the "cat /etc/fstab" thing is ?

what does cat command do ?

And I don't k'now how to to locate the right device that I'm using .
I have 2 cd drives .
1 reader and the other is writer

What to do ?

Anmar 09-10-2003 12:50 AM

I think that's what you mean:

cat /etc/fstab
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda6 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hda1 /home/anmar/.gnome-desktop/Windows vfat iocharset=iso8859-1
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0

Tel me if I'm right please .

All times are GMT -5. The time now is 01:16 AM.