-   Linux - Newbie (
-   -   can't play music with Jukebox nor Amarok (

vong'xion 03-04-2006 11:12 AM

can't play music with Jukebox nor Amarok
i have a problem playing music with jukebox and amarok.
when i open any of them and press the play button, nothing happens.:confused:

i'm using suse 9.3. pls help:cry:

Ptrs!OP 03-04-2006 11:23 AM

The best way to do this would be to set up your repositories and download amarok-xine or amarok-gstreamer.

vong'xion 03-06-2006 12:18 PM

after all the hard work there is still no joy. linux can be a pain for newbie hey?

i installed(think i did) amarok g-streamer.rpm but still there is no progress. how do i know if it actually is installed though? somewhere i found that i have to install taglib; tried but there are installation errors.

isn't there a better way. anything just to get my music playing

Ptrs!OP 03-06-2006 01:15 PM

It isn't really difficult. I don't know if you have setup your sources correctly. I have posted my sources list in my blog if you want them. After adding them you could search yast for "mp3" or "codecs" and install all packages that seem relevant.

Ptrs!OP 03-06-2006 01:35 PM

Wait wait, I forgot you are using suse 9.3 and not 10.0 OSS! Don't put my installation sources on your YaST, they are for 10.0! I remember that 9.3 had this problem with mp3, because you have to uninstall and install another package, but I don't remember anymore. If you search on LinuxQuestions threads for "mp3 playback Suse 9.3" you will certainly find what you are looking for. Or you could switch to 10.0 that is more recent and easier to setup.

vong'xion 03-06-2006 02:52 PM

it seems like now i have a bit of feel of what is going on.

let me restructure the question now:
i installed gstreamer and amarok 1.2. it looks like the g-streamer is the
mp3 plugin for amarok. in amarok's engine i don't have this plugin though the
only plugins i have 4 sound are aRts and aKode.

what do i need to do to get the g-streamer in the list?

Ptrs!OP 03-06-2006 05:17 PM

I've been doing a little bit or reading for you. I have had Suse 9.3 and I had resolved the lack of mp3 playback but I remember it was not that easy. So:
1) it seems gstreamer and arts are compiled without mp3 support on official suse 9.3 repositories.
2) you probably have gstreamer installed but not amarok-gstreamer or something like that, that would be the engine. There is also amarok-xine etc.
3) to get actual mp3 support you need to remove some packages and install other versions
4) if you think it does worth it, seeing suse 9.3 is old and buggy while 10.0 is a lot better and more recent, easier to install mp3 support and with 10.1 about to be released, then there are many threads that answer that question, try searching the forum. I did a little research for you but didn't find these threads, although I am sure that they are here because I have seen them.

Ptrs!OP 03-06-2006 05:20 PM

Or -another idea- did you try getting the multimedia packs first using YOU? And then getting amarok-gstreamer?

Ptrs!OP 03-06-2006 05:26 PM

and if that doesn't work found one of the threads:
I hope this helps

vong'xion 03-07-2006 04:16 PM

i tried all suggested and it all looked fine until more problem arose.

still in amarok, i now get a msg saying: "some url were not suitable for the playlist" when i try to select an mp3 file to play.

secondly, 1 or 2 other mp3 files load successfully, but when i try to play them i get a msg saying: "gst_engine claims it cannot play mp3 files. you may want to choose a different engine ......."

this process is such a's just impossible! everytime i try something it just doesnt work. did everyone pay the same price when they were newbies?

oh by the way what are blogs?

Ptrs!OP 03-07-2006 04:37 PM

I am really sorry to see that your first experience with linux is so problematic but actually no, we haven't all been through all that. I think that you have actually chosen the most difficult distribution to setup for mp3 support! Suse 9.3 has always had that problem. This is why I have been hinting if you want to think about changing the distribution you are using and moving on to a more recent one.

Blog is a kind of internet calendar. Blog = web + log. There are many nice blogs on line, and you can even find on linuxquestions. My signature links to mine.

vong'xion 03-08-2006 07:04 AM

for what it is worth i have to thank you for your time and effort. i'm at least glad that in my process of trying to solve my problem i actually learnt more.

with regards to the distribution, i will consider changing to 10.0 hoping for the best.


Ptrs!OP 03-08-2006 10:31 AM

I hope you'll have better luck it. Don't get discouraged though. You chose a relatively old distribution. Find a newer one that does it for you and you will be learning a lot more and will start having fun.

All times are GMT -5. The time now is 10:21 AM.