LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-14-2004, 07:00 AM   #1
mindspin
LQ Newbie
 
Registered: Oct 2003
Location: NL.
Distribution: Fedora Core 2
Posts: 29

Rep: Reputation: 15
Cant mount HD


Hi

Im having a problem, i got a dual boot Laptop with XP / Fedora 2 running on it. When im in linux i would like to access my mp3's. But somehow im not able to mount my disk in linux...

What should be the right command to mount a FAT32 disk?

btw i have tried locating the disk using the fdisk command but that doesnt seem to work

Tnx

Mindspin
 
Old 09-14-2004, 07:08 AM   #2
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
First off, make a place to mount the Win drive. From a console ...
Code:
su
<enter root password>
mkdir /mnt/win
then edit the /etc/fstab file and put this line in ...
Code:
/dev/hda1 /mnt/win vfat users,umask=000,rw,auto 0 0
That will mount the win drive at /mnt/win for all users at boot time.

Baldrick
 
Old 09-14-2004, 07:27 AM   #3
mindspin
LQ Newbie
 
Registered: Oct 2003
Location: NL.
Distribution: Fedora Core 2
Posts: 29

Original Poster
Rep: Reputation: 15
I did exactly what you did, but somehow while booting into fedora an error is displayed which says something like the filesystem is not right, maybe youre trying to mount an logical drive instead of blabla... (dont know the exact error, somewhere to check?)

So im not getting it mounted right now... what to do? try?
 
Old 09-14-2004, 07:30 AM   #4
mindspin
LQ Newbie
 
Registered: Oct 2003
Location: NL.
Distribution: Fedora Core 2
Posts: 29

Original Poster
Rep: Reputation: 15
hmm, this is the error i get while booting:
mount: Bad filesystem, bad option, bad superblock on /dev/hda2
or too many mounted filesystems (arent you trying to mount an extended partition, instead of some logical partition inside?)
 
Old 09-14-2004, 07:32 AM   #5
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
Are you sure the WinXP partition is FAT32? Another question I have to ask is what's the output of
Code:
/sbin/fdisk -l
Run that command as root from a terminal, copy the text and post it here. I just took a guess that your WinXP partition was hda1, but I could've been wrong.

Baldrick

Last edited by Baldrick65; 09-14-2004 at 07:33 AM.
 
Old 09-14-2004, 07:38 AM   #6
mindspin
LQ Newbie
 
Registered: Oct 2003
Location: NL.
Distribution: Fedora Core 2
Posts: 29

Original Poster
Rep: Reputation: 15
I cant access the internet from my laptop (posting this form another pc), so pasting is a bit tricky. But im gonna try giving you the most relevant info...

/dev/hda1/ * HPFS/NTFS
/dev/hda6/ W95 FAT32
/dev/hda7/ HPFS/NTFS

the rest of the partitions i see are linux partitions, so i doubt youll need that info . But i guess ill have to make hda2 in the fstab hda6. It should work then?

Gonna try right now.
 
Old 09-14-2004, 07:42 AM   #7
mindspin
LQ Newbie
 
Registered: Oct 2003
Location: NL.
Distribution: Fedora Core 2
Posts: 29

Original Poster
Rep: Reputation: 15
yeah, i got it working right now.
Thnx for helping me out with the fdisk -l thingie (forgot to get root first )
gonna enjoy my mp3's now
 
Old 09-14-2004, 07:42 AM   #8
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
OK, so I'm guessing that you want to mount the /dev/hda6/ W95 FAT32 partition. In that case, put this in /etc/fstab
Code:
/dev/hda6 /mnt/win vfat users,umask=000,rw,auto 0 0
That's all there is to it

But if you want to mount the NTFS partition, then add this:
Code:
/dev/hda1 /mnt/win ntfs umask=0,user,codepage=850,iocharset=iso8859-15,noauto,ro,exec 0 0
This will be READ ONLY.

Baldrick
 
Old 09-14-2004, 01:33 PM   #9
jim41025
LQ Newbie
 
Registered: Sep 2004
Distribution: RedHat 9.0, for now. . . .
Posts: 2

Rep: Reputation: 0
My problem's a little different.

Okay, so I'm trying to do something similar, but getting nowhere.

I'm working on a dual-boot desktop PC, and trying to mount an NTFS partition within RedHat 9.0. When I issue the command:

mount -t ntfs /dev/hda1 /mnt/ntfs

I get the error:

mount: fs type ntfs not supported by kernel

Now, I'm about as newbie as it gets when it comes to Linux/Unix, but I did think to check:

My NTFS partition is, in fact, /dev/hda1 (according to /sbin/fdisk -l).
The directory /mnt/ntfs does exist.
I'm logged into the current shell as root.
The man pages for the mount command list ntfs as an available file system.

(I know, the error's rather straightforward, but you never know....)

My kernel is version 2.4.20-8. Do I need to upgrade/downgrade/recompile my kernel? I couldn't find any reference to issues mounting ntfs partitions in the errata for my kernel.

 
Old 09-15-2004, 06:02 AM   #10
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
Quote:
mount: fs type ntfs not supported by kernel
Bingo ... you need to compile NTFS support into your kernel. I'm not sure what the deal is with RedHat and not including NTFS support in the default kernel. Do a quick search on RedHat and NTFS here and see what you get.

Baldrick
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to give not-root user ability to mount devices to any mount point??? jdupre Linux - General 8 02-04-2012 10:03 AM
NFS mount of smb mount of windows share: permission denied problem :( Bagatur Linux - Networking 4 07-07-2009 11:34 AM
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 07:29 PM
can mount C not D FAT: invalid media value (0x45) mount: wrong fs type, bad option Emmanuel_uk Linux - Newbie 10 11-29-2005 02:47 AM
automount: mount(generic): failed to mount (null) (type iso9660) on /mnt/media/ vasudevadas Slackware 5 10-17-2005 03:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration