LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't mount as non-root user (https://www.linuxquestions.org/questions/linux-newbie-8/cant-mount-as-non-root-user-77393/)

thepenguinhippy 07-30-2003 03:12 PM

Can't mount as non-root user
 
Ok, I've searched this and many other forums. I've read the man pages. I've done "info mount". I have edited fstab with the proper entries, including the user option to allow non-root users to mount some smbfs shares. For some damn reason, I STILL get "mount: only root can do that" when I try to mount those smbfs shares. I can mount them as root, but then I get read-only access to the shares as non-root and no matter what I do with permissions on the mount point it does the same thing.
Is something overriding the user option? This is driving me kinda nuts.

TIA,
Chris

phoeniXflame 07-30-2003 03:18 PM

for a quick fix you could try looking into using sudo to allow others to mount, have a read through http://www.courtesan.com/sudo/man/sudo.html

slightcrazed 07-30-2003 03:28 PM

I think there is some permission info in your smb.conf file..... that would be the most likely culprit. :)

slight

thepenguinhippy 07-30-2003 03:29 PM

Thanks, but...
 
Thanks, man. The bigger issue for me I guess is the read-only access I'm getting. That's why I started trying to mount it as myself (non-root). The way I have it now it's available automatically even after a boot, but I can't write to them. ?? No matter how impressed with myself I get for doing vertain things in linux, it never fails to humble me at least once in a while. I like that, though....

Thanks again,
Chris

DrOzz 07-30-2003 03:32 PM

in the fstab you can add the entry such as umask=000 or specify the user id, which is the way i do it and add uid=500
your user id may be different but in this case mine is 500:
/dev/hdc1 /mnt/80gig vfat user,rw,exec,uid=500 0 0

thats an example of what mine looks like.


All times are GMT -5. The time now is 11:48 PM.