LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Cant Login with Gnome (Permissions Error) (https://www.linuxquestions.org/questions/linux-newbie-8/cant-login-with-gnome-permissions-error-311288/)

gsoft 04-08-2005 11:08 PM

Cant Login with Gnome (Permissions Error)
 
Before logging out of gnome on the terminal. I was chaning some permissions using su. The command I used is the following

Code:

chown username:username * -R /home/username

I that this changed all the permissions in most of the / directories to the username. So I changed it using su to be root only. for the certain files.

Code:

chown root:root * -R /path/to
I first noticed the errors when XMMS wasnt able to play anything. So i tried to log in as su and it kept saying incorrect password.

I then logged out of Gnome. And found out I couldnt log back in even as the normal user as it gave me an error when it was writing data about the session. I then opted to login into failsafe which worked however again had no access to su.

Now is there anything I can do, without reinstalling. A friend said i should use Knoppix and change things that way.

P.S
If its any help at the time I believe I was in the root directory / doing the chown.

kira 04-09-2005 02:48 AM

can you login with root ?
create a new user and try again.

gsoft 04-09-2005 03:23 AM

I disabled root access in the GUI login so I cant login that way. However I also cant login as root when I go into failsafe.


All times are GMT -5. The time now is 09:10 PM.