-   Linux - Newbie (
-   -   Can't login into linux even as a root (

Zmyrgel 02-05-2006 04:45 PM

Can't login into linux even as a root
Okay, I'm using Gentoo and just installed Gnome desktop into it.

Now after few successfull runs with it I can't get in the system. Last thing I made was to make the linux start straigt into gnome. Now it does that but doesn't approve any user logon or even root logon. It just states that login name or password is wrong. I tried to change root password by chrooting using CD but I still couldn't login. Any idea what's the problem?

Also for little extra question. Why does gnome have low color amount in it? I spesified in xorg.conf that it shall use only 24bit colors.... Should I change it in somewhere else also... like some gnome specific file?

Netizen 02-05-2006 04:50 PM

Did you create a normal account? You said it doesn't work with any user account or even root, so I would assume you tried another but i wanted to check. Lots of times root is not allowed to login to X be default for security reasons.

Perhaps the driver being used in xorg.conf doesnt support 24 bit... not real sure on that one.

peter_89 02-05-2006 04:51 PM

I'm unsure regarding your password issue, but sometimes with color quality the screen resolution is too high.

Wim Sturkenboom 02-06-2006 12:40 AM

root-login into X might be blocked for security reasons. Go to a terminal (ctrl-alt-F1..6) and try to login as normal user and as root.
You definitely should be able to login as root. If you can't login as a normal user, this can be as you have tried a couple of times and the account is now locked.
Let root reset the user account.

Zmyrgel 02-06-2006 01:45 AM


One thought occured. I didn't write the command "source /etc/profile" because my keyboards numpad isn't working. I don't even know what exactly that command does. Important?

I have another user, zmyrgel which is in wheel,video,audio and portage groups. I've tried to login as both, I tried uppercase, lowercase and such.

I could login to gnome perfectly until I added it to default runlevel so it would start straight in to gnome at boot. Now I can't login at all, even after changing root password with the CD.

The same thing occured when I installed KDE on Gentoo. (I have formated the hard drive after that). I couldn't login into that also .

It's somehow related to adding any desktop environment to default runlevel...

Wim Sturkenboom 02-06-2006 03:57 AM

Forget about your 'normal' user, as I mentioned the account is probably blocked. Can you still get into a virtual terminal? Can you still login as root in a virtual terminal?

How did you add gnome (startx) to the default runlevel? Usually you change the runlevel in /etc/inittab and it will start X so what did you do?

You can use the CD to undo the latest changes that you made.

Zmyrgel 02-08-2006 07:36 AM

Okay, problem solved. It seems that KDE has root login disabled by default so that explains that and my keyboard used wrong layout so the root password given in terminal was wrong. This has been solved now.

All times are GMT -5. The time now is 05:28 PM.