-   Linux - Newbie (
-   -   Can't Log in to Desktop, root Can't Access My Files Mint 9 XFCE (

Trentixero 03-09-2011 04:46 PM

Can't Log in to Desktop, root Can't Access My Files Mint 9 XFCE
A couple weeks after I installed the xfce desktop version of Linux Mint, I became unable to log in to my own desktop. I enter my password, but the screen fades to black and then fades back in to the login screen.

I am able to log in using the recovery mode terminal and everything works as expected. I can log in to the Mint desktop as root, but the superuser can't view my files. Instead, there are only a .desktop file and a README telling me that my files have been unmounted (they're not on their own partition) and they give me instructions on how to remount them.

So I follow the instructions. Running the .desktop through the browser GUI quickly opens and closes a terminal, doing nothing. Running ecryptfs-mount-private, as the README recommends, reports:


ERROR: Encrypted private directory is not setup properly
And that's where I'm stuck.

corp769 03-09-2011 04:57 PM

Just to ask before going any further... Are you trying to log into using root the whole time? Using root to log in through your GUI should not be done; It is very unsafe.

Trentixero 03-09-2011 04:59 PM

No. I logged in as root only to see if it worked and then tried out the files that were in my user account's home folder.

corp769 03-09-2011 06:12 PM

Try looking at this:

I can't fully view it being at work, and I don't have access to linux right now. I know that's for ubuntu, but that should put you in the right direction.


Trentixero 03-09-2011 09:24 PM

I read through the article, and I think that's all I'll need if you can help me follow step 1, which asks me to mount a partition to /home. I created a generous ext4 partition for it in GParted, but I don't know how to do anything toward mounting it to /home.

corp769 03-09-2011 09:36 PM

Look in your /dev directory. Your hard drive should either be sdaX or hdaX. You need to use the mount command and mount it to whatever directory you need to. Like so:

mount /dev/sda2 /home
Of course that is an example. Read the man page to mount to learn more about it.

Trentixero 03-09-2011 10:32 PM

The instructions tell me to create a new user with my existing name, but the terminal just tells me that the account already exists.

corp769 03-09-2011 11:06 PM

So then proceed from there. I will be able to assist a lot mote once I get gome in another hour and some.

Trentixero 03-09-2011 11:12 PM

I can't. The next steps involve running the same command I tried earlier, after failing to run su on your user account. For me, the su command succeeds but ecryptfs-mount-private fails, just like it did before.

corp769 03-09-2011 11:29 PM

Ok. Will you be online in an hour? I'm leaving work in a half hour, and will be on shortly after. I will definitely assist you in troubleshooting then.


Trentixero 03-09-2011 11:32 PM

Well, I really should be going to sleep. It's not that urgent; I can still use the computer pretty well.

Oh, and now that I mounted the new partition, my /home/user directory seems to have disappeared.

^ Nevermind, this fixed itself after a restart, but I still can't log in. ^

Trentixero 03-11-2011 04:49 PM

Here's the result of me playing around with this. I'm not sure whether or not this will shed light on the problem.

The-Falconette ~ # cd /home/the-tyrian
The-Falconette the-tyrian # ls
Access-Your-Private-Data.desktop README.txt
The-Falconette the-tyrian # su the-tyrian
the-tyrian@The-Falconette ~ $ ls
Access-Your-Private-Data.desktop README.txt
the-tyrian@The-Falconette ~ $ cd .
the-tyrian@The-Falconette ~ $ ls
bin Minecraft-Server ROMs Stuff.png
Desktop Music Run-Notes_files Templates
Documents Network Run-Notes.html Videos
Downloads Pictures Screenshot1.png VisualBoyAdvance.cfg
Fencing Videos ps.txt Screenshot.png
Link to wireshark.exe Public Software.ini
the-tyrian@The-Falconette ~ $ exit
The-Falconette the-tyrian # ls
Access-Your-Private-Data.desktop README.txt
The-Falconette the-tyrian #

All times are GMT -5. The time now is 07:15 PM.