LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   cant log in (https://www.linuxquestions.org/questions/linux-newbie-8/cant-log-in-196985/)

Virtualhate 06-23-2004 07:07 PM

cant log in
 
ok i am still having problems with this suse 9.0..

after so many logins or days or whatever it is i cant log in as whatever user it is i use most, not i cant log in as root..

i get to the SuSE linux 9.0 login screen with the little icons and names to select to login i use to be able to just type root and password and it would log on..

now when i do it the screen flickers and resets back to login screen but if i switch to one of my other users it goes right on to the KDE desktop but i can then switch to terminal - Super User then login into terminal as root ..

WHAT the heck is going on here?? only thing i can think of is that there is a setting somewhere to make it not do that. and io tried YAST edit users and changed all passwords to -1 and still no luck and i cant edit root anyway so i dont know what the problem is, mabye i am suppost to register my copy of suse or something if so i dont have the box it came in anymore so oh well, if anyone has any suggestions please drop a line :)

qwijibow 06-23-2004 08:04 PM

as per default, KDE will not allow you to login as root, because...

the first rule of Fight club is... DO NOT LOGIN as ROOT !
the second rule of Fight club is... DO NOT LOGIN as ROOT !

Virtualhate 06-23-2004 10:30 PM

then why could i log in yesterday, and if it goes long enoug i wont be able to log in as anyone ..
and i need root as it is root and i can do more things like make my webpage and host ut2004 servers etc etc

qwijibow 06-24-2004 07:15 AM

read 'man su'

you should never login as root. if you need root access, use su in a terminal.

and surely you shouldnt run a game server as root !
okay.. you will need root to open up the firewall... but then you drop to an unprivilaged user to run the ut2004 server ?

dont abuse the root privilages, only give root access to programs that need it... by logging in as root you give everything roo access..... your msn messenger... your web browser, EVERYTHING. this is not a good idea.


All times are GMT -5. The time now is 09:57 AM.