-   Linux - Newbie (
-   -   Can't install Slackware Package (

Evok3 03-11-2006 08:40 AM

Can't install Slackware Package
I've recently reinstalled everyting on my computer. When it came to reinstall eciadsl I took the package I used before(I kept it on my system, save redownloading it), and tried to install the Slackware package using "installpkg". However, it executes the install process then when it gets to "executing install script..." it just exits out of the install and returns me to the shell and does nothing. I'm installing it as root too.

Any advise is much appreciated, thanks,


titopoquito 03-11-2006 09:07 AM

Sounds like the normal behaviour -- the install script usually just creates symbolic links to installed binaries and/or libraries, nothing else. It should be installed ok I guess.

If you want to check this create some empty folder where you can play around, go there and do an "explodepkg eciadsl......tgz" (replace with your package's name) and then type "less install/", then you see what the install script is all about.

Evok3 03-11-2006 10:18 AM

Are you saying that it installed correctly? Because if so, I don't think it worked. If I remember correctly, last time I installed this, after installation I had to type "eciadls-config-tk" to configue it. However, I tried to do that thinking it had installed but I got a "command not recognised". So I don't think it did install.

titopoquito 03-11-2006 11:59 AM

I can't definitely say if your package is installed correctly. I was just saying that the message you described and that nothing great happens after that is normal when installing most packages.
If you unpack the package (the "explodepkg" I mentioned) or look in the according file in /var/log/packages you see which files should have been installed -- and if eciadls-config-tk or any other file is listed there.

Evok3 03-11-2006 12:50 PM

Well thank you for your reply, I'll reboot and try a few things. I'll let you know if and how I get it sorted. Thanks again.

All times are GMT -5. The time now is 11:35 PM.