LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't install package [GNOME Phone Mangaer] (https://www.linuxquestions.org/questions/linux-newbie-8/cant-install-package-%5Bgnome-phone-mangaer%5D-642589/)

Rfahrytas 05-16-2008 04:47 AM

Can't install package [GNOME Phone Mangaer]
 
Dual boot XPSP3 and pclos 208.1

I have met this problem on some other packages as well and i have no idea how to go about fixing it.

Basically in involved dependancies, and in this particular case libcamel-1.2.so.10, when i attemp to install GNOME Phone Manager using Synapic i get this message:


Depends: libcamel-1.2.so.10 but it is not installable


I have search here an google without luck ... so clearly it is not a very common event ... *wince*

Any ideas most welcomed.

Thanks,

Rfah

knudfl 05-16-2008 05:29 PM

You are right, takes some hours to figure out :
2 packages are needed, 'evolution-data-server-1.12.3-1pclos2007.i586.rpm'
(dependent on 'libsoup-2.2.104-1pclos2007.i586.rpm') both from this adress :
http://linuxstation.net/pub/pclinuxo...-01/RPMS.main/
You can add it to /etc/apt/sources list, must look like this :
"rpm http://linuxstation.net/pub/pclinuxos/apt/ pclinuxos/2007_2008-03-01 main"
without the quotes.

Good luck !

Rfahrytas 05-18-2008 06:21 AM

Quote:

Originally Posted by knudfl (Post 3155736)
You are right, takes some hours to figure out :
2 packages are needed, 'evolution-data-server-1.12.3-1pclos2007.i586.rpm'
(dependent on 'libsoup-2.2.104-1pclos2007.i586.rpm') both from this adress :
http://linuxstation.net/pub/pclinuxo...-01/RPMS.main/
You can add it to /etc/apt/sources list, must look like this :
"rpm http://linuxstation.net/pub/pclinuxos/apt/ pclinuxos/2007_2008-03-01 main"
without the quotes.

Good luck !

OK Knudfl ... much appreciate ur help. I have downloaded libsoup and evolution rpm's .... changed the repository line in 'sources.list' [commented out the active one] and attempted to install GNOME-Phone from that repos .. but now get...

" Depends: libical.so.0 but it is not installable"


So then tried installing the rpm's [which i downloaded from the link u gave me] via terminal with these results:

installing libsoup tells me this:

package libsoup-2.4.1-1pclos2007 (which is newer than libsoup-2.2.104-1pclos2007) is already installed

and won't allow install of Evolution rpm due dependency:

error: Failed dependencies:
libsoup-2.2.so.8 is needed by evolution-data-server-1.12.3-1pclos2007.i586



Should i revert to libsoup-2.2.104 ?? How? OMG ... feel i am in too deep?

Sorry bout this but all i want to do is get phone software that is close to Nokia Win Suite [WAMMU doesn't really do it for me ] and then i will be virtually all done in migrating .... instead of first becoming an Linux Tech *smile* .... there is plenty of time for that after i give WINdoze the flick.

So just want to install GNOME-Phone to evaluate it. I may find it doesn't do the job as i expect either, in which case I suppose i will need WINE and just install Nokia Win Suite under Linux .... BUT i want to get completely away from WINdoze ... and would prefer NOT to install WINE.

[Don't u just hate compromise *LOL*]

Thank you for ur patience ... it is very much appreciated *smile*

Rfah

knudfl 05-19-2008 04:55 AM

Don't remember, may be I just uninstalled the newer version
of 'libsoup', nothing depended on it.


All times are GMT -5. The time now is 01:35 PM.