-   Linux - Newbie (
-   -   can't install linux-headers-2.6.21 (

baghdadi13 09-05-2007 03:30 PM

can't install linux-headers-2.6.21
I have Linux debian etch with kernel 2.6.21-2-686 SMP, when i tried to install ndiswrapper (for my wireless network ( it says that it can't find linux-header-2.6.21-2-686 , ,I don't have connection on my Debian, so i downloaeded a linux-header and installed it, but it was not the right one , I looked in the Debian packages web site and tried some other headers that have the same version number but no one was good
so can you please give me a link to this header because I can't find it myself

I tried these :

one of the error messages is :


debian1:/home/bagh/n# dpkg -i linux-headers-2.6.21-2-686_2.6.21-6~bpo.1_i386.deb(Reading database ... 99944 files and directories currently installed.)
Preparing to replace linux-headers-2.6.21-2-686 2.6.21-6~bpo.1 (using linux-headers-2.6.21-2-686_2.6.21-6~bpo.1_i386.deb) ...
Unpacking replacement linux-headers-2.6.21-2-686 ...
dpkg: dependency problems prevent configuration of linux-headers-2.6.21-2-686:
linux-headers-2.6.21-2-686 depends on linux-headers-2.6.21-2 (= 2.6.21-6~bpo.1); however:
Version of linux-headers-2.6.21-2 on system is 2.6.21-6.
dpkg: error processing linux-headers-2.6.21-2-686 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:

AlucardZero 09-05-2007 05:45 PM


linux-headers-2.6.21-2-686 depends on linux-headers-2.6.21-2 (= 2.6.21-6~bpo.1)
You need to get linux-headers-2.6.21-2 too.

baghdadi13 09-05-2007 06:02 PM

but I didn't find them , i've tried all the version 2.6.21 , but no one is good, and i don't know where is it !!!!!!

i treid also this one (which seems to be the exact wanted version), but it didn't work

baghdadi13 09-06-2007 03:34 AM

perhaps the problem is that the headers are nor installed in the googd place, because I have treid all the headers that I know , but no one was good

All times are GMT -5. The time now is 10:45 AM.