LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-11-2010, 01:11 PM   #1
nicholls15
Member
 
Registered: Jun 2004
Location: Dublin
Distribution: Ubuntu Intrepid
Posts: 31

Rep: Reputation: 16
Cant install fglrx on Debian Squeeze Kernel 2.6.35


Hi Folks

I recently installed Debian Squeeze on Acer Aspire 5542 , it has a Ati Radeon HD 4200 graphics card

I want to install the fglrx drivers , I apt-get install fglrx-driver, fglrx-glx & fglrx-control , The packages & dependencies download fine but when apt tries to install them the fglrx-modules-dkms fails .

The Kernel is 2.6.35.

Does anybody know how to get around this issue , Any help would be greatly appreciated been not able to sort this out since Friday
 
Old 11-11-2010, 01:22 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852
Currently there are only two ways around this issue:
1. Use kernel 2.6.32
2. Don't use fglrx

It is a bug in the ATI-drivers, and I hope it will be fixed before Squeeze goes stable and Testing and Unstable get a newer kernel.

Edit: A simple google with the keywords "2.6.35 fglrx" would have saved you a lot of time.

Last edited by TobiSGD; 11-11-2010 at 01:24 PM.
 
1 members found this post helpful.
Old 11-12-2010, 03:18 AM   #3
nicholls15
Member
 
Registered: Jun 2004
Location: Dublin
Distribution: Ubuntu Intrepid
Posts: 31

Original Poster
Rep: Reputation: 16
Hi Tobi

Thanks for the reply , I got it sorted as you suggested , first time compiling a kernel.

With regards "Just Google 2.6.35 fglrx" I'm sure I did over the past week , but hey I may have taken the Looooooooonnnnnnng way around but learnt a hell of a lot , so there is a plus .

Thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fglrx & Debian Squeeze not letting Xorg start William (Dthdealer) Linux - Software 5 02-17-2010 05:01 AM
[SOLVED] How install Flash 64 on Debian Squeeze 64 bit? AleLinuxBSD Debian 14 12-28-2009 04:27 AM
[SOLVED] install 64bit (using 32bit) Debian squeeze. kaz2100 Debian 1 11-16-2009 08:09 PM
aren't there install cd images for Debian Testing (Squeeze)? Cage47 Debian 8 11-09-2009 01:45 AM
kernel 2.6.30rc7 make and compile errors on debian squeeze dougallinux Linux - Kernel 6 05-28-2009 06:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration