LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't get screen resolution tighter than 800x600 (https://www.linuxquestions.org/questions/linux-newbie-8/cant-get-screen-resolution-tighter-than-800x600-617005/)

philwynk 01-28-2008 08:19 PM

Can't get screen resolution tighter than 800x600
 
Hi, all,

My machine has a legacy nvidia Gforce card -- Gforce 4, I'm told, and the tag on the card itself says 4.17.00.45.AF. For some reason, the boot loader recognizes the card, but won't let me set screen resolution tighter than 800x600.

It hasn't always been this way, the first several times I booted the machine it allowed me to set resolution at 1024 x 768, which would be just fine for me. But it hasn't let me do that for a week or two.

I just installed the livna nvidia legacy driver to see if that would improve things. Now my bootup gives me an impressive "nvidia" splash screen, twice... but my resolution is still at 800x600, and won't let me set anything tighter.

What I'm suspecting is that some signal from the monitor itself is missing, and that's limiting what the card will send.

Is there a way for me to change my configuration to force the card to attempt a higher resolution? And a related question, now that I'm using livna's driver, is /etc/X11/xorg.conf still the controlling configuration file, or do I need to modify something else?

Thanks for your help.

Phil W.

bigrigdriver 01-28-2008 08:47 PM

Assuming your bootloader is grub, add 'vga=791' or 'vga=792' to the kernel line in /boot/grub/menu.lst: vga-791 is for 16bit color, and vga=792 if for 24bit color, 1024x768 resolution.

philwynk 01-28-2008 09:18 PM

Thanks, but that didn't do it.

The resolution of the screen during the bootup changed, which was pretty interesting -- I saw a cute Linux penguin at the top of the bootup display for the first time, very cool, and the text was way smaller. But as soon as the bootup got past the udev load (second displayed item in the bootup process after loading the kernel) and the kernel loaded the X drivers, it reverted to the 800x600 display I've become used to.

I need something to force Xorg into 1024.

This may be TMI, but here's what I suppose is the relevant segment of my /etc/X11/xorg.conf file:
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Isn't there a resolution command for the "Screen" section of this?

Thanks again.

Phil W.

philwynk 01-28-2008 09:35 PM

I just tried adding
Modes "1024x768"
to my xorg.conf file. No effect. Does the livna nvidia-legacy driver use some other config file?

brianL 01-29-2008 03:42 AM

Try running, as root:

xorgconfig

It will ask a lot of questions, so you'll need to know in advance details such as your monitor's horizontal & vertical refresh rates.

philwynk 01-29-2008 09:35 AM

Quote:

Try running, as root:

xorgconfig
Doesn't exist in my path. Is this anything like "X -config"?

jay73 01-29-2008 10:13 AM

Hm, yes, xorgconf is on it's way out along with xorgcfg and xorgconfig. It's a shame that more and more distros are dropping those.

Well, my suggestion would be to check whether your xorg.conf explicitly lists vertical and horizontal refresh rates for your monitor. If not, put them in.


All times are GMT -5. The time now is 02:16 AM.