-   Linux - Newbie (
-   -   Can't get nVidia drivers for Fedora Core 3 64-bit (

slackr007 09-27-2005 11:39 AM

Can't get nVidia drivers for Fedora Core 3 64-bit
Ok, my screen resolution is at 800x600, which sucks. Since that's the maximum I can set it to and since I don't have any drivers installed, I'm assuming that I need to get some drivers to make it higher resolution. Just stop me there if I'm wrong and save me alot of time(hopefully). So anyway, I go here to get the drivers:
Well, I click on the link to download them and it opens a page with the source of the driver(or that's what i think it is). I tried this one too:, but to no avail. The second one actually opens a download prompt, but when I tell it to go ahead and download it will download a little(usually precent complete doesn't match up with xKB of xMB downloaded) and then just sit there and not do anything. Since these are the only 2 64-bit Linux drivers, I don't know what to do. I'm not sure if this will help anyone to help me, but I didn't see any threads about this, so I had to ask. Thanks!

JimBass 09-27-2005 12:27 PM

First and foremost, you have 2 entirely different 64 bit drivers linked there. The first link points at the driver for IA64, which is the intel 64 bit chip. You may have that, but most people with 64 bit have AMD 64 bit, which is the 2nd link you provided. Both links you provided have the installer right in the middle of them. The or are what you need, depending on your architecture.

Also, you can get well beyond 800x600 resolution, but not if your X windows isn't configured for it. You should check out the file /etc/X11/XF86Config. That has all the screen sizes written in it. With the generic NVidia driver, NV, I am currently ruinning at 1280x1024 resolution.

To install the NVidia drivers, you need to kill the Xserver, and do everything from the command prompt only. If X is running, the install will fail. There are hundreds (if not thousands) of posts on how to install the NVidia drivers, so check them out. Just installing the drivers will not change your resolution however. You will have to adjust your settings, either in the file I mentioned, or through the GUI interface for it.


slackr007 09-28-2005 08:51 PM

Ok. I've got an athlon, so I know which link to use now, but that still doesn't fix the fact that the download hangs every time. It usually does something, but I have yet to get it to complete the download. Im a newb and therefore I don't know how to do a download from the terminal. That file you talk about, etc/X11/XF86Config doesn't exist. Atleast not on my machine. I searched for posts about this, but couldn't find any. Maybe I looked in the wrong forum, I'll try in all of them.

JimBass 09-28-2005 10:19 PM

Might be /etc/X11/xorg.conf, or something along those lines. Look for any config file in /etc/X11.


slackr007 10-05-2005 11:42 AM

Ok, i got that, but now I can't do it because I don't have a pre-compiled kernel. How do I make that. I don't think I even have GCC.

Ray_Kovecses 10-05-2005 12:37 PM

Follow the instructions on fedorafaq

im not sure if this works for 64 but im pretty sure it does

JimBass 10-05-2005 12:57 PM

You can also get away with getting the kernel source and kernel headers for your particular kernel. Those can be downloaded from yum, or whatever you use to update your machine.

Don't be afraid to search. Installing the NVisia drivers probably gets asked about 10 times a day on this site, if not more. I'm sure between searching here and at google, you'd have your solution faster than posting here took.

Also, most certainly install gcc. Without it you can't install from source, which sooner or later you will want to. I still don't get why Fedora doesn't install that in the base package for everyone.


slackr007 10-05-2005 07:27 PM

Ok. I don't know where to find the "fedora faq" and I don't know how to find the source on yum. I do have it and I tried to get gcc with it but that didn't work either.

johnty01 10-05-2005 08:25 PM

more specifically,

i'm a newbie too, and tried to install the drivers by downloading the rpm... that didn't work too well (forgot to turn off selinux), but using yum it was pretty effortless.

to the more experienced users out there, my question is: can you install the nvidia drivers for slackr007's case using yum? that would make things a lot easier for him.

Ray_Kovecses 10-06-2005 07:00 AM

im pretty sure you can yum all that you need

since it is 64 im not too sure......but fedora is supposed to support 64 really well..

i would try

yum search nvidia

and see what you get

slackr007 10-07-2005 03:20 PM

Ok, I looked at the faq and I found the instructions, followed them and I don't think it worked. It said to type in

yum install nvidia-glx kernel-module-nvidia-$(uname -r)
but then I get this output:

Setting up Install Process
Setting up Repos
base                100%  |============================|  1.1 kB      00:00
updates-released    100%  |============================|  951kB      00:00
Reading repository metadata in from local files
base            :#####################################2852/2852
primary.xml.gz      100%  |============================|  422 kB      00:33
MD Read    :#####################################1119/1119
updates-re :#####################################1119/1119
Parsing package install arguments
No Match for argument: nvidia-glx
No Match for argument: kernel-module-nvidia-2.6.12-1.1378_FC3
Nothing to do

I don't know if that means it finished or not, but I do know that the game I'm trying to play still doesn't work.

Ray_Kovecses 10-07-2005 03:23 PM

you need to READ there instructions......

they have a custom yum.conf you need to install

go read and try again

slackr007 10-07-2005 03:28 PM

Oops! But it says:

If you update your kernel, make sure that you install the newest nVidia driver before you start the new kernel. Here's a shortcut command that you can type in the terminal as root that makes installing the new driver easy:
. I've already installed the new Kernel. Does this mean I need to delete it and install the drivers and then reinstall it somehow?

*I'm dual-booting my machine and after I updated the kernel it's been giving me the option of whether to boot to the old one or the new one. Just thought I'd throw that out there incase it helps w/ the whole "install w/ the old kernel" idea.

Ray_Kovecses 10-07-2005 03:31 PM

no...... just get there yum.conf ..... it says something like use our configuration or something
then try again......because if the drivers are not installed then you cannot remove them
now can ya

slackr007 10-07-2005 03:35 PM

no, i meant uninstall the new kernel. the thing says that if you update your kernel, make sure you install the drivers before you update, but I didnt' know about that and updated without installing the drivers. Does this mean I need to uninstall the new kernel, use the old one to install the drivers and then install the drivers? And yes, i see the configuration thing, I'll do that real quick.

All times are GMT -5. The time now is 05:35 AM.