LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   cant get network wireless or not on ubuntu 7.04 (https://www.linuxquestions.org/questions/linux-newbie-8/cant-get-network-wireless-or-not-on-ubuntu-7-04-a-582497/)

so white and nerdy 09-05-2007 06:53 PM

cant get network wireless or not on ubuntu 7.04
 
Hey I cant get my network (wireless or wired) to work on my laptop that i just installed the latest ubuntu 7.04 on i have tried everything from changing my router settings to manually imputting everything on my router to trying to directly connect to my roadrunner box and none of it works and yes i have changed the settings on my ubuntu system and i have tried everything there as well... PLEASE HELP!!!!!!!!!!! yes i know my card works because i had freespire installed on it b4 and i just got tired of the easy overloads with it. So some one please help. I have a belkin g wireless router and my wireless card is a wavelan ieee 802.11 but im not worried about wireless really. just please help me. if you want screen shots of my settings just let me know i can do that as well. but i am doing this on my desktop so i can get whatever you send the next day.

lebabyg 09-05-2007 07:25 PM

So do you want a wireless connection or a wired connection then? Seems odd that the wired connection via ethernet isn't working. First of all make sure that you are a member of the admin group

sudo adduser <USERNAME> admin

Where <USERNAME> is your username.

Then plug via ethernet cable directly into the router from your ethernet port on your lappy and invoke:

sudo ifup eth0

This should work, if not post the output of lspci and we'll go from there.

Peacedog 09-05-2007 07:26 PM

Hi so white and nerdy, Welcome to lq. That nick name is funny, it's what my neice calls me ;-)! Any who, please post the ouput from the following commands from the laptop with everything plugged in.

Code:

/sbin/lspci -v
/sbin/lsmod
/sbin/ifconfig -a
/sbin/route -n

Let's see what card you have and see if the modules are loaded.
God luck. ;-)

zach141 09-05-2007 08:10 PM

White n Nerdy (ditto myself, BTW):

I suffered more or less these same probs with a Marvell wireless card. The system never did see that card, despite major efforts with "ndiswrapper". I've temporarily given up on wireless for that machine.

How about a simple man's answer: Are you utterly sure that the jack you plugged into (on your router) is hot? It's not unheard of for a port on the back of a router to fail; try another one.

Ultimately, I just did a restart with the PC plugged to the router on a 40' LAN cable, and it worked. (Speaking of stupid: I did spend a confused period with the router plugged to the PC with a phone cord, vice an actual LAN cable!!) Perhaps the restart with it plugged to the router was the key, 'cuz when I did that, it did see the connection.

Zach (using Ubuntu, but not smart yet)

syg00 09-05-2007 08:57 PM

Set your router to broadcast the SSID - this fixed a problem at Feisty on a system that used to work at Edgy.
This is a known issue.

so white and nerdy 09-05-2007 11:26 PM

still not workin
 
all it says when i do sudo ifup eth0 is
Quote:

ifup: eth0 already configured
i tried the port thing and it still doesnt work it is seeing my cards both wire use and wire less but yea it still doesnt work but im still trying the restart thing now

so white and nerdy 09-05-2007 11:37 PM

i restarted it and got the update thing but firefox dont work it woudnt install them though

so white and nerdy 09-05-2007 11:51 PM

nothing at all nothing NOTHING NOTHING ITS PISSING ME OFF I HAVE DONE EVERYTHING MY SSID IS ALWAYS BROADCASTED AND IDK WHAT TO DO NOW AND I CANT GET AHOLD OF A WINDOWS XP CD

Peacedog 09-06-2007 08:00 AM

Could you post the output of the commands we've asked for please?
Good luck. ;-)

so white and nerdy 09-06-2007 07:06 PM

Here is what the commands say
Quote:

bash: /sbin/lspci: No such file or directory
There is too much to type for the lsmod command if there is anything in particular you are looking for let me know
for ifconfig -a
Quote:

eth0 Link encap:ethernet HWaddr 00:00:86:48:ff:78
inet6 addr: fe80::200:86ff:fe48:ff78/64 Scope:link
up broadcast running multicast MTU:1500 METRIC:1
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:60 (60.0 b) TX bytes:468 (468.0 b
Interrupt:11 Base address:0x8400
and thats all i really need is eth0
as for/sbin/route -n
Quote:

kernel IP routing table
destination gateway genmask flags metric ref use iface
and thats it and yes i know the last one most likely is the problem i just dont know how to fix it

so white and nerdy 09-06-2007 07:58 PM

ugh i cant find anything on it

Peacedog 09-06-2007 08:24 PM

How about just
Code:

lspci -v
or
sudo lspci -v

if neither of those work you could
Code:

su -
to root with roots path (you'll want to exit after you're done.) or try
Code:

locate lspci
I'm not sure about ubuntu but something there should get us some info. As for lsmod, we really need to see the card we're dealing with to know what to look for module wise.
Good luck. ;-)

lebabyg 09-07-2007 07:19 PM

DO

sudo ifdown eth0

sudo ifup eth0

And post the output

so white and nerdy 09-09-2007 12:07 PM

hahahahaha lmfao finally i just let it sit for like 5 days off and it finally started working on wired and i aint worried about wireless lolz yay

nh_linux 09-10-2007 06:14 AM

I'm not a system administrator people but heard that wireless networking in Linux is a pain in the ***t!!! I heard it from a Network Professional who has a home server run by Ubuntu! I'm just a Linux hobbyist, thank goodness!!! Just experimenting with it is fine with me. Doing wireless networking for an employer using Linux would not be fun!!! "so white and nerdy", I sympathize with u! Gotta be better ways to deal with this.


All times are GMT -5. The time now is 04:26 AM.