LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't get dual boot, win 7 uefi and elementary freya os uefi working (https://www.linuxquestions.org/questions/linux-newbie-8/cant-get-dual-boot-win-7-uefi-and-elementary-freya-os-uefi-working-4175560571/)

shywolf 12-03-2015 06:44 PM

Can't get dual boot, win 7 uefi and elementary freya os uefi working
 
I have a gigabyte ga-990fxa-ud3 mb with windows 7 loaded on a 128GB SSD drive. I have 2 additional drives installed. The install is eufi and I'm trying to install elementary freya as second operating system. Unfortunately I can't get the dual boot working. I have my BIOS set for UEFI boot only and I keep getting a windows 7 failure when attempting to boot. The only way I was able to get the linux system to boot was to manually disconnect the non linux hard drives. Not sure what is going on but any time I installed the windows hard drives windows loader failed. Now I am not able to boot the linux drive regardless of whether or not I have the windows hds installed. I can boot elementary os from usb, however.
Very frustrating. Unfortunately I need the windows os for some of the software I am running.
I have amd fx 8350 Eight Core processor, 8 megs of memory. Any help would be greatly appreciated.

yancek 12-04-2015 10:53 AM

Probably the best thing to do is to get the boot repair software from the link below, either by downloading it and burning it to a CD and booting it or use the Elementary usb and using the instructions to install it temporarily to use. You would need to select the option once you start boot repair to Create BootInfo summary and post it or a link to the output here.

If you have windows 7 installed UEFI then you would also need Elementary UEFI. Did you do that?

shywolf 12-04-2015 11:33 AM

Sorry, Don't see a link for boot repair software. Not sure if I missed it or what.
I did do the install from usb, elementary os 64bit. I thought that UEFI was the default for the installation.
Thank you for your feedback.

yancek 12-04-2015 05:31 PM

Sorry I forgot the link, not the first time though. Below:

https://help.ubuntu.com/community/Boot-Repair

I don't use UEFI but my understanding from reading numerous other posts here is that you need to boot the installation medium in UEFI mode. Maybe the officical Ubuntu documentation at the link below will help.

https://help.ubuntu.com/community/UEFI

shywolf 12-10-2015 06:14 PM

Ok, so here's the deal. I was unable to install elementary os and get it to boot. Found that 3.1 had some bugs that wouldn't boot UEFI. I tried numerous fixes that I couldn't get to work. I ran into elementary freya 3.2 and found that this had resolved the boot issue. I have installed it and am able to boot either the linux distro or windows. Each of the operating systems have their own boot loaders. I change what I want to boot from during boot loader process. I can select windows or hit esc and load linux. Works like a charm.
Thank you for your input and assistance.

Shy


All times are GMT -5. The time now is 12:07 AM.