LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't get basic autofs function to work (https://www.linuxquestions.org/questions/linux-newbie-8/cant-get-basic-autofs-function-to-work-4175423123/)

Rockin80sRob 08-20-2012 05:07 PM

Can't get basic autofs function to work
 
I'm trying to understand how autofs works by attempting to get an abitrary test folder mounted to a mount point. Basic autofs function. When I do this, the mount point stays empty and I can't write anything to that fold/mount point any longer. I am using RHEL 5.3 and I left everyting at default except for the "/etc/auto.mymount" file addition. No NIS, LDAP, etc.

##############
/etc/auto.master
#---------------------
/misc /etc/auto.misc
/net -host
+auto.master

/mymount /etc/auto.mymount
##############

##############
/etc/auto.mymount
#---------------------
testkey :/var/tmp/test-src-mount
##############

Made the /etc/auto.mymount file with 775 permissions.
This should work. I have the all the necessary services running even though not really needed for the example above: autofs, nfs, iplock.

FYI For my specific case, I am doing a simple remote nfs mount on another backup/mirror LINUX system. Manual network mounting works fine.

silendo 08-20-2012 05:39 PM

Excuse, can you used /etc/fstab ?

chrism01 08-20-2012 08:24 PM

Try this http://www.linuxhomenetworking.com/w...FS_Automounter


All times are GMT -5. The time now is 06:15 AM.