LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't get Amarok to work (https://www.linuxquestions.org/questions/linux-newbie-8/cant-get-amarok-to-work-597885/)

Tunene 11-07-2007 05:53 PM

Can't get Amarok to work
 
Pls I just installed Kubuntu 7.10 then I tried all the multimedia tools available starting with AMarok but there is no sound all what I have is the message:Audio output unavailable; the device is busy.
Xine parameters:

what can I do?

matthewg42 11-07-2007 06:20 PM

Probably you have a soundcard with only one channel (typical for cheap integrated cards on the motherboard), and some other program is hogging that card. First, check the sound server is OFF (K menu -> system settings -> Sound system -> uncheck the "enable the sound system" checkbox). Youo may need to log out and back in again for the change to be effective.

Another thing to check is that there are no esd processes running. esd is the enlightenment sound demon and is sometimes started by some programs which use it to connect to the sound card. Sadly, they often leave the process attached to the soundcard when they terminate, and on single channel cards this can get in the way of other programs. Here's how to check and remedy this problem:
  • Open a terminal
  • In the terminal, enter the command:
    Code:

    ps aux |grep esd |grep -v grep
  • If you get any lines back, get the PIDs (second column) of the esd process(es), and then pass them as a parameter to kill, e.g. if you found an esd process with PID 12345, execute this command:
    Code:

    kill 12345
  • Run the ps command again to confirm the esd processes are dead.
  • Restart amarok.

Tunene 11-07-2007 07:24 PM

The same message persists to show even when AMAROK is started at the bash prompt and the message is: QString::arg(): Argument missing: <p>Audio output unavailable; the device is busy.<p>xine parameters:<i></i>, cdda:/1

I had unchecked "Enable the sound system" and run the "ps aux|grep esd|grep -v grep" but no process was return on the terminal. Also under the system settings I tried "test sound" then I heard nothing. But when I started the Amarok on the terminal so also a process started called "ruby" and I don't know what it means.

matthewg42 11-07-2007 08:40 PM

Ruby is a scripting language, and is used for some amarok plugins. It's quite normal for that to start with Amarok.

If it's not esd and not a sound server, lets try a different approach (although this is getting a little speculative on my part). Try this command:
Code:

sudo lsof |grep dsp
You will be prompted for your password, which you should enter. I am assuming your user is the user which was created when you installed the system, and thus will have the ability to use sudo.

If you get any output from that command, paste it into this thread in [code] tags (to aid readability).

Tunene 11-15-2007 11:40 AM

Can't get Amarok to work
 
Sorry, I have been away for a while; but the command:
sudo lsof | grep dsp
returns nothing to the terminal and everytime that I start Amarok the error message comes out with something related to "Xine parameters". So I am thinking if the problem has something to do with "alsa". When I run Adept there are several packages of "alsa" that are not installed and I do not no which one I should installed or what not. So is it possible that the error message has something to do with "alsa"?

matthewg42 11-18-2007 01:19 PM

The Xine message just means that libxine cannot open the soundcard. Usually this means another program is hogging the card, but it could mean there is no driver installed for the card.

Tunene 11-19-2007 10:07 AM

Can't get Amarok to work
 
Well maybe. But how can I install the driver for the soundcard,and if another process is hogging the xine how can I know them. I told you that I am new to Linux.

matthewg42 11-19-2007 10:59 AM

OK, first I want you to check if there is a sound server running. Please open:

K Menu -> System Settings -> Sound System -> General (tab)

There should be a check box named "Enable the sound system". If this is enabled, please click the "Test Sound" button. Do you hear any sound?

Tunene 11-21-2007 01:24 PM

Can't get Amarok to work
 
Well I did it a while ago and there is no sound when I clicked the "test sound" button

matthewg42 11-24-2007 11:55 AM

Hmm, I'm stuck here. It's hard to figure out without sitting at the machine. Sorry I can't be more help. :(

Tunene 11-25-2007 03:30 PM

Can't get Amarok to work
 
What I realized was the no sound card was installed on my system and I don't know how to install one since I don't even have it listed with the commands that I have tried. My system is Dell latitude d830 if you have any further assistance to make.


All times are GMT -5. The time now is 04:43 AM.