-   Linux - Newbie (
-   -   Can't find the nic or soundcard (

dad1001 01-15-2006 07:06 PM

Can't find the nic or soundcard
I'm fairly new and just installed Ubantu on a PIII compaq deskpro. Can't find the nic or soundcard. I'm dual booting with Mandriva LE 2005 and that can see my nic but not the soundcard.
Any ideas?


Kristijan 01-15-2006 08:33 PM


If the NIC works in Mandriva, it should work fine in Ubuntu. Try and troubleshoot with the following commands.

As root;

dmesg | grep eth
This will grep through all the information you see when your machine is booting up. Check if your eth0 is actually detected.

If it is detected, you can simply do an ifconfig eth0 up. If it's not detected, the easiest method would be to boot back into Mandriva with the working eth0 and then run the lsmod command to see what module the eth0 uses.

Once you have the module name, boot back into Ubuntu and run modprobe <module_name> and then ifconfig eth0 up.

Hopefully this gets you on your way with the NIC. As for your soundcard, can you give me some more information (i.e. Make and model)

Good luck,

dad1001 01-18-2006 09:33 PM

Hey Kristijan
Thank you for answering my post.
The output of lsmod in Mandriva is
[root@localhost dad]# lsmod
Module Size Used by
snd-pcm-oss 49056 0
snd-pcm 80776 1 snd-pcm-oss
snd-timer 20324 1 snd-pcm
snd-page-alloc 7588 1 snd-pcm
snd-mixer-oss 17248 1 snd-pcm-oss
snd 46980 4 snd-pcm-oss,snd-pcm,snd-timer,snd-mixer-oss
nfsd 210272 9
exportfs 4672 1 nfsd
lockd 59144 2 nfsd
sunrpc 122788 12 nfsd,lockd
autofs4 15268 0
mach64 52448 1
drm 58388 2 mach64
md5 3648 1
ipv6 232320 18
rfcomm 33692 0
l2cap 20644 5 rfcomm
bluetooth 41380 4 rfcomm,l2cap
ad1848 29788 0
uart401 9156 0
sound 71948 2 ad1848,uart401
soundcore 7104 2 snd,sound
af_packet 16232 2
ip_vs 92096 0
floppy 54736 0
eepro100 27056 0
mii 4224 1 eepro100
ide-cd 36772 0
loop 13544 0
supermount 32660 1
ext3 123976 1
jbd 48664 1 ext3
intel-agp 20028 1
agpgart 28264 2 drm,intel-agp
ata_piix 7268 0
libata 41572 1 ata_piix
scsi_mod 115784 1 libata
uhci-hcd 28944 0
usbcore 106008 2 uhci-hcd

When I do a
sudo dmesg | grep eth
I get this
eth0: Invalid EEPROM checksum 0xbab8, check settings before activating this device!
eth0: OEM i82557/i82558 10/100 Ethernet, 00:90:27:BC:46:8E, IRQ 11

Any thoughts?


dad1001 01-18-2006 10:03 PM

Hey again
I also posted on and together with what you gave me, and what I got there it works!
This is what I did,

don@ubuntu:~$ sudo mii-tool eth0
eth0: negotiated 100baseTx-FD flow-control, link ok
don@ubuntu:~$ ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:90:27:BC:46:8E
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

don@ubuntu:~$ lspci | grep Eth
0000:00:0d.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
don@ubuntu:~$ lspci | grep mii

don@ubuntu:~$ sudo dhclient eth0
Internet Systems Consortium DHCP Client V3.0.2
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/eth0/00:90:27:bc:46:8e
Sending on LPF/eth0/00:90:27:bc:46:8e
Sending on Socket/fallback
DHCPDISCOVER on eth0 to port 67 interval 6
DHCPREQUEST on eth0 to port 67
chown: failed to get attributes of `/etc/resolv.conf': No such file or directory
chmod: failed to get attributes of `/etc/resolv.conf': No such file or directory
bound to -- renewal in 1009841466 seconds.

dad1001 02-01-2006 07:11 AM

The story so far...
I was using Mandriva LE, but wanted to try something newer. Installed Ubantu. Seemed ok until I rebooted, upon which my os lost the nic. After messing around (the previous posts) I could get it going again, until one day I couldn't anymore.
Thinking this was an issue with Ubuntu, I installed Suse 10. The nic was found and worked until I rebooted. I reinstalled and it worked, rebooted and no worky again.

I get no output when I do a
dmesg | grep eth0

When I do a lsmod, I don't see eth0, but I do see e100.

When I do dmesg | grep e100 I see

e100: Intel(R) PRO/100 Network Driver, 3.4.8-k2-NAPI
e100: Copyright(c) 1999-2005 Inter Corporation
e100: 0000:00:0d.0: e100_eprom_load: EEPROM corrupted
e100: probe of 0000:00:0d.0 failed with error -11

What's happening? Why did it work fine in Mandriva and not in other os?
I like Suse better and want to keep using it. I was up for a week before I had to reboot and lost the nic.


dad1001 02-01-2006 10:54 PM

Ok, after messing around for a while I found a driver called eepro100. I did
dmesg | grep eepro100
dmesg | grep eth0
ifconfig eepro100 up

and it's ok.

How do I add this so it does it at boot?

All times are GMT -5. The time now is 02:36 PM.