LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't find my second hard drive (https://www.linuxquestions.org/questions/linux-newbie-8/cant-find-my-second-hard-drive-708516/)

Billerwell 03-02-2009 02:15 AM

Can't find my second hard drive
 
Hi,

Thank goodness there's a newbie section, I don't feel quite so embarrassed asking this question :/

I recently installed Red Hat Enterprise Linux 5 with a main 20GB HD, a secondary 80GB HD and a CD ROM installed.

My trouble is trying to find my secondary HD.

In /dev/ I have:-
hda
hda1
hda2
hdc
hdc1
hdd

I'm certain hdc1 is my extra HD as I mounted hdd and it gave me the CD Drive.

I made a directory for the extra hard drive:-

mkdir /mnt/storage

then I tried to mount it:-

mount -t auto /dev/hdc1 /mnt/storage

but get:-

mount: /dev/hdc1 already mounted or /mnt/storage busy

I then tried to unmount it in case it was mounted somewhere else:-

umount /dev/hdc1

and get:-

umount: /dev/hdc1: not mounted

That pretty much leaves me where I am, I've tried a number of other things without luck so I'm now up to asking for help for what I'm sure is probably a menial task, so I apologise for that.

If anyone can tell me how to find my mounted drive location (so I can save files to it) or in the case it's still not mounted, please tell me how to mount it without getting the errors.

A bit of extra info that may help. Here is the result from "fdisk -l"

Disk /dev/hda: 20.8 GB, 20847697920 bytes
255 heads, 63 sectors/track, 2534 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 13 104391 83 Linux
/dev/hda2 14 2534 20249932+ 8e Linux LVM

Disk /dev/hdc: 80.0 GB, 80054059008 bytes
255 heads, 63 sectors/track, 9732 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 * 1 9732 78172258+ 8e Linux LVM


Thanks for your time.

Markus

r3sistance 03-02-2009 02:24 AM

Hi, would appear HDC would be the one to go for, just to check, have you actually formatted the drive with ext3 or a different filing system? Also try a different mount point to /mnt/storage, it's possible that mount point itself is busy as another device maybe mounted to it.

Billerwell 03-02-2009 03:04 AM

Thanks for the quick reply.

I haven't formatted the drive as I assumed red hat did it during the install. I just tried to format it with:-

mkfs.ext3 /dev/hdc1

and got:-

/dev/hdc1 is apparently in use by the system; will not make a filesystem here!

also made another directory in /home/markus/hd2 and tried mounting again:-

mount -t ext3 /dev/hdc1 /home/markus/hd2/

and got:-

mount: /dev/hdc1 already mounted or /home/markus/hd2/ busy


Any more thoughts?

norobro 03-02-2009 09:51 AM

Issue the command:
Code:

mount
That should tell you where hdc1 is mounted

Billerwell 03-03-2009 02:00 AM

Thanks for that.

Typed 'mount" and got:-

/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hda1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)

Doesn't seem to be any mention of hdc1

norobro 03-03-2009 08:59 AM

Please post the output of:
Code:

pvdisplay
and
Code:

cat /proc/swaps

thorkelljarl 03-03-2009 09:39 AM

A perhaps naive question

Both of these HDD are formatted as LVM. Does this not mean that they present themselves to the OS as one HDD with the OS distributed across the combined disk space as if it were on one HDD.

Are there not two levels here, the partition, showing the physical HDD, and the logical, which the OS sees. Commands issued to the two levels will give you two different classes of results. You will see hdc and hdc1 on the partition table but only the Volume Group exists when you query the OS. There is no hdc and hdc1, or rather, the HDD and partition is already there, but integrated in a form you don't recognize. Look again at your results from fdisk -l.

What do you say?

Billerwell 03-04-2009 01:52 AM

Thank you very much for the info, you are spot on. Prior to today I was totally unaware of LVM or what it was, but as you've suggested both HD's have been combined to look as one and that my extra HD space has been available all along in every and any folder :(

Nice to finally have it sorted :)

Cheers,

Markus


All times are GMT -5. The time now is 12:51 PM.