LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   can't find ide.agent & block.agent for hotplug for 2.6 (https://www.linuxquestions.org/questions/linux-newbie-8/cant-find-ide-agent-and-block-agent-for-hotplug-for-2-6-a-193700/)

jg167 06-15-2004 05:07 AM

can't find ide.agent & block.agent for hotplug for 2.6
 
I'm trying to get the PCMCIA slot working with RH 9 and a 2.6.6 kernel.

First cardmgr 3.1.31 complaied that there was a release mismatch so I upgraded to 3.2.7 with the pcmcia-cs set, that seems ok, cardmgr runs. But now when I insert a CF adapter (easy first test) I get errors about
no /etc/hotplug/ide.agent
and
no /etc/hotplug/block.agent
and indeed there are none. So that should be easy... but looking at various hotplug packages releated in 2004 (jan mar may) none of them have those either. What gives? Should I not need these (and thus have something else wrong that these are being looked for in the first place?)

jg167 06-23-2004 05:20 PM

I was able to download the rpm-utils package from
javascript:openExternal(%22http://www.kaybee.org/~kirk/html/linux.html%22)

which enabled me to extract just the block.agent, generic_empty.agent, and ide.agent (the last is a symlink to generic_empty.agent) and the needed hotplug.subfs.functions files from
ftp://chuck.ucs.indiana.edu/pub/arra...2.5.noarch.rpm

whcih allowed pcmcia CF adapters and the CF slot itself to work. Once again answering my own questions.


All times are GMT -5. The time now is 07:50 PM.