LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Cant delete new folders (https://www.linuxquestions.org/questions/linux-newbie-8/cant-delete-new-folders-4175411360/)

ALWAYZBLESS 06-14-2012 02:06 AM

Cant delete new folders
 
Hey all, anytime I download something new or create a new folder it only gives it root access, under my username even logged in as root I am unable to delete it. I have tried everything I can think of but the only thing that will allow me to delete it is "chown username file name" and im sick of typing it in every time I want to delete something, so how can I make all new folders and downloads be able to be deleted while logged in under my username? Thx guys

Satyaveer Arya 06-14-2012 02:19 AM

Which OS are you using? What command/s you tried? What error/s are you getting?

ALWAYZBLESS 06-14-2012 02:33 AM

Quote:

Originally Posted by Satyaveer Arya (Post 4702819)
Which OS are you using? What command/s you tried? What error/s are you getting?

Ubuntu 12.04, and im trying to delete it using the GUI and mostly chmod and chown commands with different permissions settings.... the weird thing is all of this workng just fine yesterday and magically now my permissions are all over the place.. any idea on why any new download in terminal has a lock on it and wont let me delete?

ERROR: Unable to trash files, permission denied.

ls-l shows my username as owner of everything except the new directores that are created when I download they are owned by root, so this is only happening when new things are being downloaded through terminal

Satyaveer Arya 06-14-2012 04:40 AM

Open a terminal and login through 'root' user and then go to the Downloads directory where you have downloaded the data. Then try "rm -rf <file/directory_name>"


All times are GMT -5. The time now is 10:59 AM.