-   Linux - Newbie (
-   -   can't create lock file? (

Class Zero 01-30-2002 12:59 AM

can't create lock file?
I installed storm linux a couple days ago on a spare hard drive I had laying around. I used a hard drive tray. I'm working on Win 2000 now so that's what I'm using to get my hardware information and to post here, since Storm won't recognise my modem.

At first I thought my modem might be a win modem, but I opened up a terminal window in Win 2000 and gave it the AT command and it responded 'OK'. It's a Telepath 56k voice faxmodem PNP. I think US Robotics made it before they merged with 3com. It's an internal modem on one of those older longer slots. It's been so long since I've done serious hardware work I forget the name of the slot... you know the shorter ones that ship in new computers today I think are called PCI slots and the older ones I think are ISA slots? I could be wrong about what they're called, but it's an older internal hardware modem.

I opened up Kppp and tried to dial and it said that Kppp can not find /dev/modem. I went to settings and changed the modem and got the exact same error message when I tried cua0, cua1, cua2, cua3, ttyI0, ttyI1, ttyI2, and ttyI3. When I tried ttyS0, ttyS1, ttyS2, and ttyS3 I got the error, 'can't create lock file'.

What's a lock file, and how can I create one? Do I need to be logged on as root?


isajera 01-30-2002 01:37 AM

a lock file is a temporary file created to lock a particular resource to a program - if the modem is being used by kppp, then it can't be dialed by wvdial or something like that. (btw... this is completely separate from accessing the modem by email or browsers) it's usually created somewhere in the /var directory. it's probably necessary for the user to have write privledges to the directory where the lock file is - if the dial-up works as roor but not otherwise, this is almost definitely the problem.

Class Zero 01-30-2002 04:16 AM

trying different things...
I remembered some advice a friend told me once about installing linux for the first time... keep trying different distros untill one works.

I had another hard drive laying around so I put linux mandrake on it and it gives these errors when I try to use kppp... on /dev/cua0 and cua1 and ttyS0 and ttyS1 it shows 'looking for modem'... 'sorry, modem doesn't respond' on /dev/modem, ttyI0, ttyI1, ttyI2, and ttyI3 it shows, 'looking for modem'... 'sorry, can't open modem'. On /dev/cua2, cua3, ttyS2 and ttyS3 it shows 'looking for modem'... 'sorry, modem busy'.

I looked around and found lothar but lothar wouldn't show me anything about the modem or sound card even after I told it to detect settings. I tried looking up the lothar web page on the mandrake site but it must have been taken down since my distro was released.

Now I'm out of distros to try. I'm on dial up through an ISP that automatically kicks you off after being online for 24 hours straight no matter what. The distros I'm using are from a maximum linux magazine put out may/june of 2000.

I'll try as root. Thanks for the info.

Class Zero 01-30-2002 06:24 AM

tried root
I tried it again as root on the storm linux drive and got the same errors that mandrake gave me

All times are GMT -5. The time now is 01:52 PM.