LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   cant connect at all w/ mandrake 10 (https://www.linuxquestions.org/questions/linux-newbie-8/cant-connect-at-all-w-mandrake-10-a-226512/)

porno 09-04-2004 08:42 AM

cant connect at all w/ mandrake 10
 
just installed mandrake 10 on a athlonxp 2600 (barton) i have no experience whatsoever of linux so i'm sure it's my ignorance. however, i cant connect(blueyonder, motorola sb 4100 cable, 1 mbps) to the internet
what to do
cheers m
:newbie:

egag 09-04-2004 12:21 PM

how about canging call-sign...eh, just to get the right kind of attention,
or maybe post your Q. on a porno-site.. ( just an idea... )

( excuse me , but my paranoid mind tells me you are better known here as '' UNIXFREAK "
if not : excuses........ )

egag

porno 09-04-2004 12:30 PM

ta!!!!!!!!!!!
 
yea well sorry. happens to be my nickname(pre-web). and thanks for beeing so helpful.
remember... it's only porn if you are outside looking in

egag 09-04-2004 12:35 PM

how about the '' UNIXFREAK " thing........

egag

porno 09-04-2004 12:46 PM

?
 
i'm sure thats really funny but....... sorry mate. dont know linux, let alone unix. if this forum is for bs like this, then i dont see the point in the so called comunity itd suposed to be. i asked a question, expected an answer.. i do appolgise
oh.. keep your hands on top of the cover
m

scuzzman 09-04-2004 12:57 PM

Try running:
Code:

dhcpcd eth0
or (possibly)
Code:

dhclient
and see what errors are reported, or whether it will start working.

You're probably going to ask how to do this: simple
If you're using KDE, click the KDE button, go to System -> Terminals -> Konsole
type the commands there (may need to be root, in which case, type "su" first (no quotes) and enter your password then try.)

Oh, and welcome to LQ :D

porno 09-04-2004 01:16 PM

aha....!
 
nice one scuzzman
my hope for mankind has been somewhat restored
later
m

scuzzman 09-04-2004 01:21 PM

Which command fixed it? Just for my morbid curiosity, and for others that might be browsing the forums for the same answer.

porno 09-04-2004 01:31 PM

fix
 
dhclient
do appriciate
m

PlasticX 09-04-2004 02:36 PM

Hello, I just installed Linux for the first time and I have a similar problem to the one described above. I tried the recommended commands to no avail.

Firstly, I installed Mandrake Linux 10.0 with no network cable attached and now try to restart with cable connected. I checked the hardware list and my network hardware is listed as "supported". Do I just need to reinstall with network connected?

Anyway, here are the error messages I get (logged in as root).

dhcpcd eth0 says "Command not found"

dhclient says:

sit0: Unknown hardware address type 776
/sbin/dhclient-script: configuration for sit0 not found.

and then some "Network down" messages.

Any help would be appreciated. Thanks.

PlasticMan

irlandes 09-04-2004 07:29 PM

I am not sure, but
 
I am not sure but with Drake 9.1, several months after I installed it on my Dell laptop, I conncted the extra cable from my daughter's Road Runner router, and it instantly connected my browser with no setup at all

After a year and a half of automatic change from dial-up with KPPP, to using the router, that broke. I tried drake 10.0 since replacing rpm's didn't help, AND 10.0 COULD NOT EVEN FIND MY NIC AT ALL. I finally gave up on 10.0 and reinstalled 9.1. Now it takes like 3 minutes to set up the nic at bootup.

Did you note the messages during bootup as far as if eth0 were enebled or not?

My point here is that some folks have had 10.0 problems with eth0 eneble, and I am one of them. I saw somewhere a config file fix that was supposed to cure this, but lost it and google can't find it now.

PlasticX 09-04-2004 11:49 PM

Re: Cannot connect
 
Hmmm, sounds like a real problem here. At first, I did have a failed message for enabling eth0, but it disappeared after I fooled with the Config tool, removing and adding connections and such. Still doesn't connect, though. Maybe the failed message disappeared because now it doesn't even try to enable it.

The only message I get during boot is it complains that it can't look up the internet address for the host name and suggests adding to /etc/hosts. I think this will clear up if it can get an IP address.

I'll keep working on it - this is my first install of Linux ever, so I don't have a 9.1 install to go back to. I would appreciate any further suggestions anyone may have. I'll post here if I find a fix.

PlasticMan

scuzzman 09-05-2004 07:11 AM

The reason you got the [FAILED] message on bootup is cause the ethernet cable wasnt plugged in.
Try this:

service network restart
- or -
service network start

kersten78 09-05-2004 11:01 AM

Make sure eth0 is listed in ifconfig. If it isn't, run ifconfig eth0 up and then run dhclient. I highly doubt that it wouldn't be listed in ifconfig on boot, but you never know. One other thing to check is the file /etc/sysconfig/network-scripts/ifcfg-eth0 It should contain something similar to:
DEVICE=eth0
BOOTPROTO=dhcp
NETMASK=255.255.255.0
ONBOOT=yes

I think that it's possible to assign a default gateway in ifcfg-eth0 as well, but I'm not sure. It hasn't been necessary in mine. Good luck and let us know your progress.
-Kris

PlasticX 09-05-2004 11:24 AM

eth0 fails every time
 
Actually, I had stopped getting the [FAILED] message but now I get it every time on bootup. This started after I found another post which led me to use "ifconfig eth0 up" because the eth0 interface was not listed when I typed just "ifconfig".

I tried "service network restart" and also get [FAILED] when it gets to "bringing up interface eth0".

SELECT COUNT(*) FROM this_user WHERE clue>0;
<no rows returned>

PlasticMan


All times are GMT -5. The time now is 11:42 AM.