-   Linux - Newbie (
-   -   Can't boot new Mandrake 8.0 install (

Radagast 01-22-2002 01:12 AM

Can't boot new Mandrake 8.0 install
I downloaded Mandrake 8.0 ISO images and created 2 CD's, which I used to install Linux on an extra machine I built from hand-me downs from my other machines (see end of post for full config). This machine has no floppy drive and the CD-ROM drive is on the motherboard's primary IDE controller as a master. The 13.6GB Maxtor HD is on a Promise Ultra-66 controller's primary IDE as a master.

The disk has other OS'es installed already and has been partitioned with PartitionMagic 6.0 as follows:

Primary Partitions:
Part#1 - FAT16 - 133.3 MB - MS-DOS 7.0 (no windows)
Part#2 - FAT32 - 2,000.3 MB - Windows 98 SE
Part#3 - extended - 10,848.6 MB

Logical Partitions:
Part#4 - NTFS - 2,000.2 MB - Windows NT 4.0 (not working)
Part#5 - FAT32 - 2,000.2 MB - Windows data
Part#6 - ext2fs - 1,702.2 MB - Linux root
Part#7 - FAT16 - 133.3 MB - MS-DOS 7.0 (no windows)
Part#8 - ext2fs - 1,702.2 MB - Linux data
unallocated - 1,608.1 MB
Part#9 - FAT32 - 1,702.2 MB - Windows data

The install from the Mandrake 8.0 installation CD's went fine, but when it finally rebooted without the CD to run the new OS, when I picked linux from the menu, the LILO loader failed with messages:

request_module[block-major-33]: Root fs not mounted
VFS: Cannot open root device "2107" or 21:07
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 21:07

booting back into Windows 98 SE worked fine though. After trying every suggestion I found on the net about this LILO boot error, and reinstalling several times, I finally decided that LILO just couldn't handle the switch of drive device identities when the system booted from the HD, rather than the CD (i.e., /dev/hde7 had become /dev/hda7). I had even tried changing these device names in /etc/lilo.conf from hde7 to hda7, but it didn't help.

So I gave up on LILO and tried installing GRUB from the CD system to the HD system, as detailed in the GRUB user guide. The setup (or install) commands worked fine in GRUB that was running from the CD booted system (the "rescue" system), but any attempt to actually boot from that partition (hd0,6) resulted in a blank screen and no activity, requiring a reboot (reset switch).

I was able to reinstall BootMagic from the Windows 98 system, but when I selected the Linux partition to boot from, it only rpinted the "Preparing to boot Mandrake 8.0 system ..." and then no further activity (about the same as I get from my never fully installed NT 4,0 partition).

I ran Norton DiskEdit from the DOS partition and found evidence of grub (a string) in the second sector (track 782, side 1, sector 1) of the 6th partition, so it would appear that the install of grub was performed to the right place, but it won't run.

What else can I do to get this system running?

Full hardware config:

Tyan S1590S Trinity 100AT motherboard
AMD K6-2 450MHz
Diamond Stealth 2000 S3 Virge-DX PCI graphics
Magnavox 15" monitor
Avance ALS-100 SB-compatible ISA sound board
Promise Ultra-ATA/66 PCI IDE controller
Maxtor Diamond Max 6800 13.6GB ATA-4/UDMA 66
(generic) 44X ATAPI CD-ROM
(generic) serial mouse & AT-style keyboard

Chijtska 02-12-2002 09:36 PM

you need to make sure that hda6 (root) partition starts at least below the 1024th cylinder... i haave come upon this same problem with my suse6.2 and slackware as well.... iuse normally mandrake 8.1 and it has this bug worked out but im not sure if 8.0 does or not...

in order to make that happen youre going to have to do some data shuffling.... but ill bet yu anything thats prob whats wrong

Radagast 02-13-2002 06:02 AM

Thanks, Chijtska

I thought I had figured out that that was the problem too. In fact, the first time I did the install, it picked partition 8 (which was interpreted as hde7), as shown in my previous message, as the root, even though I thought I had told it to install into partition 6. Partition 6 did start below the 1024 cylinder mark, but 8 didn't. So I completely wiped that install, and just to make sure, slightly reduced the size of partition 6 so that it, and the swap partition, were entirely below the 1024 cylinder mark. I then reinstalled, making sure that it went into partition 6 and not 8.

The only difference was that my error message on reboot changed to '... device "2105" or 21:05' (instead of 21:07). Which at least indicated that it had gotten into the correct partition. Besides I had checked the doc for Mandrake 8.0 and it said that it included support for the Promise Ultra-ATA/66 PCI IDE built-in to the kernel and support for greater than 1024 cylinders, so I shouldn't have had a problem with starting cylinder anyway. At least the repeat of the problem, even below 1024 cylinders, would seem to verify that that was not the problem.

I thought, based on some other messages I found via Google, that maybe LILO wasn't handling the switch of disk 0/disk 1 properly when I rebooted without a bootable CD, so I tried reinstalling in Expert mode and specifying GRUB as my boot loader (actually, I tried to switch to GRUB and configure it from the last LILO install, in recovery mode from the install CD, but that didn't work either). But the main difference was that I didn't even get a boot flash screen or error message ... nothing but a blank screen! :confused:

I've been doing a lot of Win2000 stuff lately so the Linux install is still at that point. I'm still open to any suggestions. I've been thinking maybe the problem might be "fixed" in Mandrake 8.1 (although such a problem is not mentioned anywhere in the release notes). Do you think it's worth downloading 2 more CD images and burning 2 more CD's to find out? :(

boblucci 02-13-2002 12:24 PM

i sugjest that you get a floppy drive and reinstall linux and create the bootable floppy.

Did you make the root partition bootable?

I would also say to get rid of some of those partitions!!!

When the LILO menu came up did it have an option to boot to 4 different places?

ms-dos 7.0

can you post your lilo.conf file?

Chijtska 02-13-2002 01:46 PM

remember you can always create a bootable floppy and you can use your linux... if that still doesnt work maybe theyres X issues... if you must have lilo install linux then i seriously doubt 8.1 will be that different...

while it is true there is a good difference in the two i havent noticed anything different as far as the bootloader is installed. still the same old thing... although, i do believe just because you choose the newbie install method it should still at least ask you how you want lilo configured if at all but...thats another thread...

Radagast 02-14-2002 03:35 AM

There is no floppy drive on this machine and I don't want to buy one when I can boot off of the CD-ROM. The boot from CD-ROM or hard disk works fine for Win98SE. Are you telling me that Linux can't do as well?

I've tried both LILO and GRUB. What else is there?

I don't think 8 partitions is an unreasonable amount for a 13.6GB drive with 3 or 4 OS'es installed. Win98 has no problem with that many partitions. I have 11 partitions on my 90GB Win2K (only) system. I've been running multi-partitioned and multi-drive systems for many years (up until recently, all of my systems were SCSI based, but SCSI got too expensive, and IDE performance got good enough, so I switched for my past few systems :) ).

When the LILO menu from the original install came up, it did have entries for dos, win98 & win-nt (I actually used the boot to win98 successfully). By the time I tried experimenting with GRUB, I had reinstalled PQ's BootMagic into the MBR, so I just tried to install GRUB into the partition boot record for the root partition. When I try this boot, the last display I get is from BootMagic saying it is preparing to boot from the Linux partition, then nothing (at least LILO gave me an error message, cryptic as it was).

I have looked at the first sector of the Linux root partition from DOS with an old Norton Utilities (back when they were actually useful, like reading and writing sectors), and it looked like the GRUB information I had installed was there (at least I saw a few familiar strings in that sector). I just can't get it to take control from BootMagic and load the Linux kernel. :rolleyes:

Chijtska 02-14-2002 08:25 AM

dude chill ;), Ive only been using linux for a few weeks myself.. i just did my first triple boot a few days ago (it has some sort of problems itself)... im just sayin i dont really know how to get it done... lilo is pretty good and may not be easy to understand but i think (to me, IMHO etc) that boot magic really blows... so i have been satisfied to use a floppy bootdisk... also you can make a floppy cdrom since you dont have a floppy drive... (i know they seem to be archaic these days but they do come in use with boot problems and yu can get one for only 15$).... sorry i was not able to help... i just thought originally that the dreaded 1024th cylinder may have been the culprit.. good luck!

Chijtska 02-14-2002 08:25 AM

a boot cdrom i meant to say...

Radagast 02-14-2002 02:41 PM

Well, thanks for the ideas, Chijtska. :cool:

If I sounded a little upset, it was in response to boblucci's suggestion that getting rid of some partitions would make a difference. Or that a boot floppy was necessary to make this work.

I am set on getting this system to work without a floppy. I feel that floppy's are obsolete and I bought my last one several years ago and I don't want to buy a new one just to create and use one boot floppy. If Linux can't handle this requirement, then it is not yet ready for prime time. The rescue system on the install CD runs perfectly, so I do have command line Linux access to my system. I just don't know what to tweak to get the installed system going.

Does anyone know a LILO or GRUB expert that can help me diagnose this problem? I willl try to copy down my LILO and/or GRUB config files and post them. Until I get this system up and running though, I can't transfer the files via the network and post them easily. :(

BTW, what problems have you had with BootMagic? I've used it for years (and Quarterdeck's Select-It and V Communications's System Commander before that), without any major problems (I had to switch to BootMagic when I started using FAT32, because Select-It was no longer being updated). I used to run several different versions of Windows, DOS, and OS/2 with these products. I have used BootMagic to boot Linux (Caldera 2.0) a few years ago, but I just didn't have the time to invest in Linux back then (plus, I'm a GUI kind of guy and the Linux GUI wasn't quite ready for prime time back then).

Chijtska 02-14-2002 10:45 PM

here is mine:

append=" hdc=ide-scsi devfs=mount"
append=" hdc=ide-scsi devfs=mount failsafe"

append=" hdc=ide-scsi devfs=mount failsafe"

maybe it will give you an idea because my linux partitions ARE above the 1024th cylinder...

good luck dude

Radagast 02-15-2002 03:33 AM

Thanks again, Chijtska. :cool:

I just realized that I can't check out my LILO config, because my last install was a complete wipe and reinstall in expert mode, where I specified GRUB as my boot loader, so I no longer have a LILO config. However, I will keep your post handy for my next attempt to install (perhaps with 8.1).

Ciao! :)

Don Paul (a.k.a. Radagast) :study:

Chijtska 02-15-2002 07:56 AM

oh sorry... i feel pretty stupid about now... good luck don paul-- i have only played around with grub once and to be honest, to me, lilo made more sense...

All times are GMT -5. The time now is 07:16 PM.