-   Linux - Newbie (
-   -   can't boot linux after moving drives - "Kernel panic - not syncing: No init found" (

ET_ 09-21-2010 12:03 AM

can't boot linux after moving drives - "Kernel panic - not syncing: No init found"
This is my first post here. I usually find answers just reading, but this time I need to ask for help.
I moved my boot drive and windows drive to a different controller on my motherboard, as well as move the drives that make my linux RAID to different ports, but in the same controller. I ended up with the Kernel panic error.
I then read that when moving drives fstab and lilo.config need to be changed accordingly. I did that by entering though a live cd. Now the problem is booting into Linux and running the command lilo, as I've read I have to after changing lilo.config.

If this actually isn't going to fix the problem. Then I would really appreciate any help on the matter.


Bruce Hill 09-21-2010 12:44 AM

Could you not run "lilo" from the LiveCD?

Possibly boot the Slackware CD1 and choose your present
/ fs where your drive is actually located. Then you would
be in your system and "lilo" should work.

Another method is to boot with Slackware CD1 then chroot
into your system.

As for the RAID you'll need to reassemble it once you get
the system sorted out.

prayag_pjs 09-21-2010 01:29 AM


As stated above use rescue mode.You can also use trail and error method like trying root(tab--->)[to get the device naming] at grub prompt.Also kernel tab key...

ET_ 09-21-2010 02:08 AM

Thanks you guys. I tried your suggestions, but it only half worked. I was able to use the lilo command, but it couldn't overwrite the old install for some reason. So I went searching some more and found a script to reinstall lilo and that solved everything. I appreciate your help though.



ET_ 09-21-2010 05:16 AM

by the way, to any onlookers
the script in slackware was "liloconfig".
It skips the installation all the way to the lilo setup part. Solved everything.
I realize now that the drive names didn't change either. Even though sda was moved to a different controller and shouldn't be sda anymore(more like sde), it still held as sda.


All times are GMT -5. The time now is 11:20 PM.