LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't access usb key in slackware 10.1 (https://www.linuxquestions.org/questions/linux-newbie-8/cant-access-usb-key-in-slackware-10-1-a-349449/)

thorney 08-03-2005 12:08 AM

Can't access usb key in slackware 10.1
 
Hi,

I tried using the command:

mount /dev/sda1

which is what I usually use to mount my usbdisk in FC4 but that didn't work. I tried going into konquerer and looking at the devices that are listed and my usb key wasn't there. I know that the usb key is fine cuz I just used it seconds ago.
Anyone have any ideas?

thanks,

thorney

Nylex 08-03-2005 01:50 AM

What happens when you issue "mount /dev/sda1"? Any error messages?

goldennuggets 08-03-2005 06:53 AM

you'll either have to add the mount to your fstab, or login as root and do the whole shabang,
mount -t vfat /dev/sda1 /mnt/flash
or something to that effect, it's been a while since I've done that.

enemorales 08-03-2005 06:56 AM

As goldennuggets said:

Code:

mount -t vfat /dev/sda1 /mnt/flash
as root will mount the driver in /mnt/flash (so you need to create this directory if it does not exist). If that goes fine, you can create an entry in yout /etc/fstab file to use only "mount /dev/sda1/"

HTH

phil.d.g 08-03-2005 07:41 AM

plug in your usb drive and then issue `dmesg` in a terminal, you'll get something like this near the end:
Code:

SCSI device sda: 128000 512-byte hdwr sectors (66 MB)
sda: Write Protect is off
sda: Mode Sense: 03 00 00 00
sda: assuming drive cache: write through
 sda: sda1
Attached scsi removable disk sda at scsi8, channel 0, id 0, lun 0
usb-storage: device scan complete

which tells you what device the pendrive has been assigned

thorney 08-03-2005 11:21 AM

I'll give all these things a try.

thanks everyone

thorney 08-03-2005 11:32 AM

I edited /etc/fstab with

Code:

/dev/sda1      /mnt/usbdisk      vfat      defaults      0      0

and then the command "mount /dev/sda1" worked fine.

goldennuggets 08-03-2005 11:35 AM

excellent. glad to hear your success.


All times are GMT -5. The time now is 06:21 PM.