LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Cant access linux filesystem ext3 after upgrading from mdk 9.1 to mdk 10 (https://www.linuxquestions.org/questions/linux-newbie-8/cant-access-linux-filesystem-ext3-after-upgrading-from-mdk-9-1-to-mdk-10-a-295542/)

drewineal 02-27-2005 01:28 PM

Cant access linux filesystem ext3 after upgrading from mdk 9.1 to mdk 10
 
I went to upgrade from 9.1 to 10.0 i have two hard drives one mounted at / and the other mounted at /home. The installation didnt recognize my monitor and hung so i had to hit the power. After installing in non graphical mode and getting my monitor to work the hardrive at /home was corrupted or something i can't access it. I think the first mistake i made was when it asked about partitions to load 10.0 on i just specified the /dev/hdc to mount at / and left the other hard disk /dev/hdd field blank thinking i could just mount it at /home when i was finished. Mandrake control center says that it is linux native but it won't mount. i tried

root@bresnan hd]# mke2fs -n /dev/hdd5
mke2fs 1.34 (25-Jul-2003)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
9781248 inodes, 19535040 blocks
976752 blocks (5.00%) reserved for the super user
First data block=0
597 block groups
32768 blocks per group, 32768 fragments per group
16384 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624, 11239424


then used

[root@bresnan hd]# fsck.ext2 -b 163840 /dev/hdd5
e2fsck 1.34 (25-Jul-2003)
fsck.ext2: Bad magic number in super-block while trying to open /dev/hdd5

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193

and tried that with the different super-block numbers but i always get the above error message.

So any help would be great i don't know if all my information is lost or if im just not doing the right things. Ive upgraded mandrake before and never had any problems
Thanks

Mara 02-27-2005 03:45 PM

Are you sure it was Ext2? Maybe you used ReiserFS? Try
fsck.reiserfs /dev/hdd5


All times are GMT -5. The time now is 07:37 AM.