-   Linux - Newbie (
-   -   can't access fat partition with normal user account (

gilebo 04-12-2006 10:32 AM

can't access fat partition with normal user account

I know this is a question that has been posted a zillion times (if not more...), and I have read a lot about it already. It simply will not work on my box and I am a bit desperate.

I am running a Suse Linux 10.0SS box. The problem:

although I have let Yast edit the fstab and have tried myself a couple of times as well, I can't get user write access on ANY of the fat drives I mounted. I can go into the directory, so the fat partitions are mounted. I can read and write with root access. I just can't write using a user account(which I really need).

So this is how my fstab looks at the moment, the appropriate partitions that is:
/dev/hda1 /windows/Boot vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/hda6 /windows/Documenten vfat user,iocharset=utf8 0 0
/dev/hda9 /windows/Download vfat rw,umask=000 0 0

As you can see I have been trying a bit, but none works.

So then I read somewhere that I should use chmod on the directories, e.g. with a root console: chmod -R 777 .... Interestingly enough, the permissions are NOT changed, if any partition is mounted. If they are not mounted, I can clearly see the permissions being changed. So I am guessing, here is where the problem lies. I just for the love of God can't see the solution...

Thanks in advance

maggie29 04-12-2006 11:17 AM

Maybe this post will help you?
That whole thread might help, really, but it's a little deep for me. Just looked like what you're asking. :)

gilebo 04-12-2006 12:33 PM


I think, I found the answer myself. All I needed to do, is to umount the partition using the user account and then mount it again by hand. That was it. Then the permissions were magically changed into what I needed. I never tried it before, cause I was always using a root console to mount and unmount the **** partition.

the trick:

umount /mount_point as user (e.g /mnt/windows)


mount /mount_point also as user

jeroensnake 04-27-2006 07:56 AM

I have about the same problem. I have mounted a vfat partition with mostly music and movies. But sometimes, out of the blue, i cannot delete or create files. Unmount and mount again (as root); it works again. But it keeps changing back to read-only for some reason.

So what is causing this problem, and how can I fix it? I dont feel like unmount,mount.unmount,mount.unmount,mount, you get my drift...

the line from my /etc/fstab:
/dev/hda5 /mnt/d vfat defaults,dev,user,gid=users,uid=jeroensnake,umask=0022 0 0

drkstr 04-27-2006 11:42 AM

this is all you need in /etc/fstab, should work fine:


/dev/hdb1        /mnt/fat      vfat    users,defaults,umask=000  0  0
I think the problem is in your umask= line, why do you have 4 digits? The above will allow any user to have rwx privlages, adjust acordingly if you don't want execute privlages. ALso, make sure the folder you are mounting it to has the same privlages that you desire.


All times are GMT -5. The time now is 12:49 PM.