LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't access audio CDs with grip/xmms (https://www.linuxquestions.org/questions/linux-newbie-8/cant-access-audio-cds-with-grip-xmms-79713/)

Phantomas 08-06-2003 11:34 PM

Can't access audio CDs with grip/xmms
 
Hi,

I'm having problems accessing audio cds. I can mount data CDs fine, so i'm reasonably sure that my fstab is set up correctly.

I've searched around and found that other's have had the same problem, and that audio cd's can't be mounted because they don't have a file structure... Most of the responses i've found go along the lines of "run grip and it will open the audio cd for you" Unfortunately this hasn't been the case for me...

If i run grip --verbose i get the following:

Checking for a new disc
CDStat said no disc
Checking for a new disc
CDStat said no disc
...

Same goes with xmms. I try to add the /cdrom dir from the playlist, but it's empty.

Do i have to look into setting up super/auto mount on my system to get this going? I'm running Debian sarge.

Any help here would be greatly appreciated :)
Ryan

scott_R 08-06-2003 11:39 PM

You shouldn't have anything mounted to access your audio cds. the "mounting" should be done by your program, xmms, grip, and so on. Chances are, your problem is that you somehow have that drive mounted, so you need to unmount it, or remove whatever mounting you added.

slakmagik 08-06-2003 11:41 PM

I'm not familiar with your particulars or if this is the best or only way, but I changed ISO9660 to 'auto' in my fstab

/dev/sr0 /mnt/cdrw auto noauto,users 0 0

Basically, I think if it's set as ISO9660 and you stick a non-ISO9660 disk in there, it reads it as no disk. I think that was what did it, though I was changing around a lot of stuff at the time. *g*

Phantomas 08-06-2003 11:43 PM

Wow, that was quick :)

I've just found that grip can open audio cds when i'm logged in as root, but not user. I tried adding myself to the 'cdrom' group, but that didn't work. ANy other ideas?

slakmagik 08-06-2003 11:47 PM

That's what the 'users' part of my line is for or, at least, it's so I can mount and unmount as user. I don't know if that also governs playing CDs. And, actually, I don't know why adding yourself to a group that does have permissions wouldn't work. You may need to log back in to have that take effect? I'm not sure.

Phantomas 08-07-2003 12:04 AM

Oh my god...

All i had to do was chmod 755 /dev/cdrom

So simple that i thought it wouldn't have been an issue. I could access data cd's before as user, So i figured i had user access permissions already. Weird.

Thanks for the help fellas. That was slightly embarrassing :)

Ryan

alex.e.c 08-21-2003 03:53 AM

Jesus, thanks guys, that's exactly what I had to do... now onto the ripping...


All times are GMT -5. The time now is 03:27 PM.